summaryrefslogtreecommitdiffhomepage
path: root/luci.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2020-04-15 12:24:15 +0200
committerJo-Philipp Wich <jo@mein.io>2020-04-15 12:44:57 +0200
commit62be45c466ff70cb22278cc64f3a55fdb7dbbf19 (patch)
tree3feecedfb1072f2ba54b2b0f5c5083bdfb73ba62 /luci.mk
parent09a84607508f289488d7185692ed8e9eb66053ac (diff)
build: luci.mk: fix compatibility with older Git versions
Fixes: 9d8e99f9b build: gracefully handle non-Git source trees Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'luci.mk')
-rw-r--r--luci.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/luci.mk b/luci.mk
index 0b3a66e3b..d7a89d9ff 100644
--- a/luci.mk
+++ b/luci.mk
@@ -64,7 +64,7 @@ PKG_NAME?=$(LUCI_NAME)
define findrev
$(shell \
if git log -1 >/dev/null 2>/dev/null; then \
- set -- $$(git log -1 --format="%ct %h" --abbrev=7 -- '$(if $(1),:(exclude))po'); \
+ set -- $$(git log -1 --format="%ct %h" --abbrev=7 -- $(if $(1),. ':(exclude)po',po)); \
if [ -n "$$1" ]; then
secs="$$(($$1 % 86400))"; \
yday="$$(date --utc --date="@$$1" "+%y.%j")"; \