diff options
author | Jo-Philipp Wich <jo@mein.io> | 2020-04-09 23:08:13 +0200 |
---|---|---|
committer | Jo-Philipp Wich <jo@mein.io> | 2020-04-09 23:23:33 +0200 |
commit | 59fe4086f3a93f919547154373ac3d5e975e7db2 (patch) | |
tree | 17afdbfb933ccf4491cb28967bb140d87477f9bd /luci.mk | |
parent | c099344013ad72d01a93b99184c72c5eeb792174 (diff) |
build: luci.mk: drop support for non-Git SCMs
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'luci.mk')
-rw-r--r-- | luci.mk | 18 |
1 files changed, 4 insertions, 14 deletions
@@ -60,20 +60,10 @@ LUCI_LC_ALIAS.zh_Hant=zh-tw PKG_NAME?=$(LUCI_NAME) PKG_VERSION?=$(if $(DUMP),x,$(strip $(shell \ - if svn info >/dev/null 2>/dev/null; then \ - revision="svn-r$$(LC_ALL=C svn info | sed -ne 's/^Revision: //p')"; \ - elif git log -1 >/dev/null 2>/dev/null; then \ - revision="svn-r$$(LC_ALL=C git log -1 | sed -ne 's/.*git-svn-id: .*@\([0-9]\+\) .*/\1/p')"; \ - if [ "$$revision" = "svn-r" ]; then \ - set -- $$(git log -1 --format="%ct %h" --abbrev=7); \ - secs="$$(($$1 % 86400))"; \ - yday="$$(date --utc --date="@$$1" "+%y.%j")"; \ - revision="$$(printf 'git-%s.%05d-%s' "$$yday" "$$secs" "$$2")"; \ - fi; \ - else \ - revision="unknown"; \ - fi; \ - echo "$$revision" \ + set -- $$(git log -1 --format="%ct %h" --abbrev=7); \ + secs="$$(($$1 % 86400))"; \ + yday="$$(date --utc --date="@$$1" "+%y.%j")"; \ + printf 'git-%s.%05d-%s' "$$yday" "$$secs" "$$2" \ ))) PKG_GITBRANCH?=$(if $(DUMP),x,$(strip $(shell \ |