summaryrefslogtreecommitdiffhomepage
path: root/libs/rpcd-mod-rrdns/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2017-07-10 18:38:03 +0200
committerJo-Philipp Wich <jo@mein.io>2017-07-11 14:05:31 +0200
commit74affdf6f515073a881c0278fdb6cc5e15d97a6b (patch)
treef0ef2937fa65e8c3ad8c625a057a848fc5591597 /libs/rpcd-mod-rrdns/Makefile
parent366707a681459a4d520dc97024ea0a4b3c24a326 (diff)
rpcd-mod-rrdns: add new rpcd plugin for rapid reverse DNS lookups
The plugin provides a new ubus procedure "network.rrdns.lookup" which allows looking up the names of a large chunk of IP addresses at once, within a fixed global timeout. This is useful to have a guaranteed maximum query time even if the local DNS setup is broken or timing out. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'libs/rpcd-mod-rrdns/Makefile')
-rw-r--r--libs/rpcd-mod-rrdns/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/libs/rpcd-mod-rrdns/Makefile b/libs/rpcd-mod-rrdns/Makefile
new file mode 100644
index 0000000000..f0bf140a87
--- /dev/null
+++ b/libs/rpcd-mod-rrdns/Makefile
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2016-2017 Jo-Philipp Wich <jo@mein.io>
+#
+# Licensed under the Apache License, Version 2.0.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rpcd-mod-rrdns
+PKG_VERSION:=20170710
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
+
+PKG_LICENSE:=Apache-2.0
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/rpcd-mod-rrdns
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Rapid reverse DNS rpcd module
+ DEPENDS:=+rpcd +libubox +libubus
+endef
+
+define Package/rpcd-mod-rrdns/description
+ Provides rapid mass reverse DNS lookup functionality.
+endef
+
+define Package/rpcd-mod-rrdns/install
+ $(INSTALL_DIR) $(1)/usr/lib/rpcd
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/rrdns.so $(1)/usr/lib/rpcd/
+endef
+
+define Package/rpcd-mod-rrdns/postinst
+#!/bin/sh
+killall -HUP rpcd 2>/dev/null
+exit 0
+endef
+
+$(eval $(call BuildPackage,rpcd-mod-rrdns))