summaryrefslogtreecommitdiffhomepage
path: root/libs/rpcd-mod-luci/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2019-10-31 14:01:38 +0100
committerJo-Philipp Wich <jo@mein.io>2019-11-01 12:03:28 +0100
commitb292c1d5fa1773c76162fd35fe5324c774a9cf87 (patch)
tree6d55112cd7fb9cdc5e8e9f99a03276ddf5b4fd95 /libs/rpcd-mod-luci/Makefile
parent4798b3f062ae19e0563665874e27d62d921cb641 (diff)
libs: add rpcd-mod-luci
Add rpcd-mod-luci, a fast rpcd C plugin for speeding up common backend ubus operations. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'libs/rpcd-mod-luci/Makefile')
-rw-r--r--libs/rpcd-mod-luci/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/libs/rpcd-mod-luci/Makefile b/libs/rpcd-mod-luci/Makefile
new file mode 100644
index 0000000000..8efeee9d28
--- /dev/null
+++ b/libs/rpcd-mod-luci/Makefile
@@ -0,0 +1,54 @@
+#
+# Copyright (C) 2016-2017 Jo-Philipp Wich <jo@mein.io>
+#
+# Licensed under the Apache License, Version 2.0.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=rpcd-mod-luci
+PKG_VERSION:=20191031
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
+
+PKG_LICENSE:=Apache-2.0
+
+PKG_BUILD_PARALLEL:=1
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+TARGET_CFLAGS += \
+ -I$(STAGING_DIR)/usr/include/libnl-tiny \
+ -I$(STAGING_DIR)/usr/include \
+
+CMAKE_OPTIONS += \
+ -DLIBNL_LIBS=-lnl-tiny \
+
+define Build/Prepare
+ $(INSTALL_DIR) $(PKG_BUILD_DIR)
+ $(CP) ./src/* $(PKG_BUILD_DIR)/
+endef
+
+define Package/rpcd-mod-luci
+ SECTION:=libs
+ CATEGORY:=Libraries
+ TITLE:=Rapid reverse DNS rpcd module
+ DEPENDS:=+rpcd +libubox +libubus +libiwinfo
+endef
+
+define Package/rpcd-mod-luci/description
+ Provides rapid mass reverse DNS lookup functionality.
+endef
+
+define Package/rpcd-mod-luci/install
+ $(INSTALL_DIR) $(1)/usr/lib/rpcd
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/luci.so $(1)/usr/lib/rpcd/
+endef
+
+define Package/rpcd-mod-luci/postinst
+#!/bin/sh
+killall -HUP rpcd 2>/dev/null
+exit 0
+endef
+
+$(eval $(call BuildPackage,rpcd-mod-luci))