summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/docsrc/nixio.bit.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/nixio/docsrc/nixio.bit.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/nixio/docsrc/nixio.bit.lua')
-rw-r--r--libs/nixio/docsrc/nixio.bit.lua92
1 files changed, 0 insertions, 92 deletions
diff --git a/libs/nixio/docsrc/nixio.bit.lua b/libs/nixio/docsrc/nixio.bit.lua
deleted file mode 100644
index 6951dd532..000000000
--- a/libs/nixio/docsrc/nixio.bit.lua
+++ /dev/null
@@ -1,92 +0,0 @@
---- Bitfield operators and mainpulation functions.
--- Can be used as a drop-in replacement for bitlib.
-module "nixio.bit"
-
---- Bitwise OR several numbers.
--- @class function
--- @name bor
--- @param oper1 First Operand
--- @param oper2 Second Operand
--- @param ... More Operands
--- @return number
-
---- Invert given number.
--- @class function
--- @name bnot
--- @param oper Operand
--- @return number
-
---- Bitwise AND several numbers.
--- @class function
--- @name band
--- @param oper1 First Operand
--- @param oper2 Second Operand
--- @param ... More Operands
--- @return number
-
---- Bitwise XOR several numbers.
--- @class function
--- @name bxor
--- @param oper1 First Operand
--- @param oper2 Second Operand
--- @param ... More Operands
--- @return number
-
---- Left shift a number.
--- @class function
--- @name lshift
--- @param oper number
--- @param shift bits to shift
--- @return number
-
---- Right shift a number.
--- @class function
--- @name rshift
--- @param oper number
--- @param shift bits to shift
--- @return number
-
---- Arithmetically right shift a number.
--- @class function
--- @name arshift
--- @param oper number
--- @param shift bits to shift
--- @return number
-
---- Integer division of 2 or more numbers.
--- @class function
--- @name div
--- @param oper1 Operand 1
--- @param oper2 Operand 2
--- @param ... More Operands
--- @return number
-
---- Cast a number to the bit-operating range.
--- @class function
--- @name cast
--- @param oper number
--- @return number
-
---- Sets one or more flags of a bitfield.
--- @class function
--- @name set
--- @param bitfield Bitfield
--- @param flag1 First Flag
--- @param ... More Flags
--- @return altered bitfield
-
---- Unsets one or more flags of a bitfield.
--- @class function
--- @name unset
--- @param bitfield Bitfield
--- @param flag1 First Flag
--- @param ... More Flags
--- @return altered bitfield
-
---- Checks whether given flags are set in a bitfield.
--- @class function
--- @name check
--- @param bitfield Bitfield
--- @param flag1 First Flag
--- @param ... More Flags
--- @return true when all flags are set, otherwise false \ No newline at end of file