summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/docsrc/nixio.TLSContext.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/nixio/docsrc/nixio.TLSContext.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/nixio/docsrc/nixio.TLSContext.lua')
-rw-r--r--libs/nixio/docsrc/nixio.TLSContext.lua46
1 files changed, 0 insertions, 46 deletions
diff --git a/libs/nixio/docsrc/nixio.TLSContext.lua b/libs/nixio/docsrc/nixio.TLSContext.lua
deleted file mode 100644
index 7cc071195a..0000000000
--- a/libs/nixio/docsrc/nixio.TLSContext.lua
+++ /dev/null
@@ -1,46 +0,0 @@
---- Transport Layer Security Context Object.
--- @cstyle instance
-module "nixio.TLSContext"
-
---- Create a TLS Socket from a socket descriptor.
--- @class function
--- @name TLSContext.create
--- @param socket Socket Object
--- @return TLSSocket Object
-
---- Assign a PEM certificate to this context.
--- @class function
--- @name TLSContext.set_cert
--- @usage This function calls SSL_CTX_use_certificate_chain_file().
--- @param path Certificate File path
--- @return true
-
---- Assign a PEM private key to this context.
--- @class function
--- @name TLSContext.set_key
--- @usage This function calls SSL_CTX_use_PrivateKey_file().
--- @param path Private Key File path
--- @return true
-
---- Set the available ciphers for this context.
--- @class function
--- @name TLSContext.set_ciphers
--- @usage This function calls SSL_CTX_set_cipher_list().
--- @param cipherlist String containing a list of ciphers
--- @return true
-
---- Set the verification depth of this context.
--- @class function
--- @name TLSContext.set_verify_depth
--- @usage This function calls SSL_CTX_set_verify_depth().
--- @param depth Depth
--- @return true
-
---- Set the verification flags of this context.
--- @class function
--- @name TLSContext.set_verify
--- @usage This function calls SSL_CTX_set_verify().
--- @param flag1 First Flag ["none", "peer", "verify_fail_if_no_peer_cert",
--- "client_once"]
--- @param ... More Flags [-"-]
--- @return true \ No newline at end of file