summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/axTLS/samples/vbnet/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-02-22 23:19:25 +0000
committerSteven Barth <steven@midlink.org>2009-02-22 23:19:25 +0000
commitd730c1263328c5990ce46cdf6394ce6e36cc3609 (patch)
tree8dc37350e69dcbd0ca82570cfa62a4c710defc93 /libs/nixio/axTLS/samples/vbnet/Makefile
parentd2b11117f26285186b711271d24733d35e0444a1 (diff)
Add axTLS sourcecode
Diffstat (limited to 'libs/nixio/axTLS/samples/vbnet/Makefile')
-rw-r--r--libs/nixio/axTLS/samples/vbnet/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/libs/nixio/axTLS/samples/vbnet/Makefile b/libs/nixio/axTLS/samples/vbnet/Makefile
new file mode 100644
index 000000000..0984d4e02
--- /dev/null
+++ b/libs/nixio/axTLS/samples/vbnet/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (c) 2007, Cameron Rich
+#
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# * Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+# * Redistributions in binary form must reproduce the above copyright
+# notice, this list of conditions and the following disclaimer in the
+# documentation and/or other materials provided with the distribution.
+# * Neither the name of the axTLS project nor the names of its
+# contributors may be used to endorse or promote products derived
+# from this software without specific prior written permission.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
+# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
+# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
+# OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
+# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+
+include ../../config/.config
+include ../../config/makefile.conf
+include ../../config/makefile.dotnet.conf
+
+# only build on Win32 platforms
+ifdef GO_DOT_NET
+all : sample
+TARGET=../../$(STAGE)/axssl.vbnet.exe
+sample : $(TARGET)
+
+$(TARGET): ../../bindings/vbnet/axTLSvb.vb ../../bindings/vbnet/axInterface.vb axssl.vb
+ vbc.exe /r:"`cygpath -w "$(CONFIG_DOT_NET_FRAMEWORK_BASE)/System.dll"`" /nologo /t:exe /out:"`cygpath -w $@`" $(foreach file, $^, "`cygpath -w $(file)`")
+
+endif # ARCH
+
+clean::
+ -@rm -f $(TARGET)
+