summaryrefslogtreecommitdiffhomepage
path: root/libs/nixio/axTLS/samples/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/nixio/axTLS/samples/Makefile
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/nixio/axTLS/samples/Makefile')
-rw-r--r--libs/nixio/axTLS/samples/Makefile62
1 files changed, 0 insertions, 62 deletions
diff --git a/libs/nixio/axTLS/samples/Makefile b/libs/nixio/axTLS/samples/Makefile
deleted file mode 100644
index afbdd43d1b..0000000000
--- a/libs/nixio/axTLS/samples/Makefile
+++ /dev/null
@@ -1,62 +0,0 @@
-#
-# Copyright (c) 2007, Cameron Rich
-#
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are met:
-#
-# * Redistributions of source code must retain the above copyright notice,
-# this list of conditions and the following disclaimer.
-# * Redistributions in binary form must reproduce the above copyright
-# notice, this list of conditions and the following disclaimer in the
-# documentation and/or other materials provided with the distribution.
-# * Neither the name of the axTLS project nor the names of its
-# contributors may be used to endorse or promote products derived
-# from this software without specific prior written permission.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
-# CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED
-# TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY
-# OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
-# NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
-# THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-#
-
-all:
-
-include ../config/.config
-include ../config/makefile.conf
-
-all:
-ifdef CONFIG_C_SAMPLES
- $(MAKE) -C c
-endif
-ifdef CONFIG_CSHARP_SAMPLES
- $(MAKE) -C csharp
-endif
-ifdef CONFIG_VBNET_SAMPLES
- $(MAKE) -C vbnet
-endif
-ifdef CONFIG_JAVA_SAMPLES
- $(MAKE) -C java
-endif
-ifdef CONFIG_PERL_SAMPLES
- $(MAKE) -C perl
-endif
-ifdef CONFIG_LUA_SAMPLES
- $(MAKE) -C lua
-endif
-
-clean::
- $(MAKE) -C c clean
- $(MAKE) -C csharp clean
- $(MAKE) -C vbnet clean
- $(MAKE) -C java clean
- $(MAKE) -C perl clean
- $(MAKE) -C lua clean