summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-px5g
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-01-09 13:19:28 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-09 13:19:28 +0100
commitf4fb5871255701a0e635a1fc1d7fa6d653cde3d7 (patch)
treec1e3c14209c3a51f408ea737e4f8bf438099f458 /libs/luci-lib-px5g
parent3c6d03ddee6ba4a536b687b17aa5a41f1f2d1575 (diff)
luci-lib-px5g: add missing src Makefile and fix depends
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-px5g')
-rw-r--r--libs/luci-lib-px5g/Makefile2
-rw-r--r--libs/luci-lib-px5g/src/Makefile17
2 files changed, 18 insertions, 1 deletions
diff --git a/libs/luci-lib-px5g/Makefile b/libs/luci-lib-px5g/Makefile
index 906a1052e..ee07ba0f5 100644
--- a/libs/luci-lib-px5g/Makefile
+++ b/libs/luci-lib-px5g/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
LUCI_TITLE:=RSA/X.509 Key Generator (required for LuCId SSL support)
-LUCI_DEPENDS:=+luci-lib-nixio
+LUCI_DEPENDS:=+liblua
include ../../luci.mk
diff --git a/libs/luci-lib-px5g/src/Makefile b/libs/luci-lib-px5g/src/Makefile
new file mode 100644
index 000000000..755565e2b
--- /dev/null
+++ b/libs/luci-lib-px5g/src/Makefile
@@ -0,0 +1,17 @@
+PX5G_CFLAGS = -I. -include polarssl/rsa.h -include polarssl/x509.h -std=gnu99
+PX5G_LDFLAGS = -llua -lm
+PX5G_OBJ = px5g.o library/bignum.o library/havege.o library/rsa.o library/sha1.o library/timing.o library/x509write.o
+PX5G_LIB = px5g.so
+
+%.o: %.c
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LUA_CFLAGS) $(PX5G_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: $(PX5G_OBJ)
+ $(CC) $(LDFLAGS) -shared -o $(PX5G_LIB) $(PX5G_OBJ) $(PX5G_LDFLAGS)
+
+install: compile
+ mkdir -p $(DESTDIR)/usr/lib/lua
+ cp $(PX5G_LIB) $(DESTDIR)/usr/lib/lua/$(PX5G_LIB)
+
+clean:
+ rm -f *.o *.so