summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-px5g/src/px5g.h
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-px5g/src/px5g.h
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-px5g/src/px5g.h')
-rw-r--r--libs/luci-lib-px5g/src/px5g.h16
1 files changed, 16 insertions, 0 deletions
diff --git a/libs/luci-lib-px5g/src/px5g.h b/libs/luci-lib-px5g/src/px5g.h
new file mode 100644
index 0000000000..47542b5c06
--- /dev/null
+++ b/libs/luci-lib-px5g/src/px5g.h
@@ -0,0 +1,16 @@
+#include <lua.h>
+#include <lualib.h>
+#include <lauxlib.h>
+
+#include "polarssl/havege.h"
+#include "polarssl/bignum.h"
+#include "polarssl/x509.h"
+#include "polarssl/rsa.h"
+
+#define PX5G_KEY_META "px5g.key"
+
+typedef struct px5g_rsa {
+ int stat;
+ havege_state hs;
+ rsa_context rsa;
+} px5g_rsa;