summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-px5g/root
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-px5g/root
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-px5g/root')
-rwxr-xr-xlibs/luci-lib-px5g/root/usr/sbin/px5g-genkeys19
1 files changed, 19 insertions, 0 deletions
diff --git a/libs/luci-lib-px5g/root/usr/sbin/px5g-genkeys b/libs/luci-lib-px5g/root/usr/sbin/px5g-genkeys
new file mode 100755
index 000000000..87a66bfe2
--- /dev/null
+++ b/libs/luci-lib-px5g/root/usr/sbin/px5g-genkeys
@@ -0,0 +1,19 @@
+#!/usr/bin/lua
+local keyfile = "/etc/nixio/rsa_main.der"
+local certfile = "/etc/nixio/cert_main.der"
+
+local px5g = require "px5g"
+local nixio = require "nixio"
+local fs = require "nixio.fs"
+local os = require "os"
+nixio.umask(77)
+
+if not fs.access(certfile) then
+ local key = px5g.genkey(2048)
+ fs.writefile(keyfile, key:asn1())
+
+ local cert = key:create_selfsigned(
+ {CN=nixio.uname().nodename, O="LuCI Keymaster"},
+ os.time(), os.time() + 3600 * 24 * 366 * 15)
+ fs.writefile(certfile, cert)
+end