summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/src/cyassl-compat.h
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/src/cyassl-compat.h
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/src/cyassl-compat.h')
-rw-r--r--libs/luci-lib-nixio/src/cyassl-compat.h32
1 files changed, 32 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/src/cyassl-compat.h b/libs/luci-lib-nixio/src/cyassl-compat.h
new file mode 100644
index 000000000..b2cdc9233
--- /dev/null
+++ b/libs/luci-lib-nixio/src/cyassl-compat.h
@@ -0,0 +1,32 @@
+#define WITH_CYASSL
+#define WITHOUT_OPENSSL
+#include <openssl/ssl.h>
+
+typedef unsigned int word32;
+
+
+#define MD5_DIGEST_LENGTH 16
+typedef struct MD5_CTX {
+ int dummy[24];
+} MD5_CTX;
+
+void InitMd5(MD5_CTX*);
+void Md5Update(MD5_CTX*, void*, word32);
+void Md5Final(MD5_CTX*, void*);
+
+
+#define SHA_DIGEST_LENGTH 20
+typedef struct SHA_CTX {
+ int dummy[24];
+} SHA_CTX;
+
+void InitSha(SHA_CTX*);
+void ShaUpdate(SHA_CTX*, void*, word32);
+void ShaFinal(SHA_CTX*, void*);
+
+int MD5_Init(MD5_CTX *md5);
+int MD5_Update(MD5_CTX *md5, void *input, unsigned long sz);
+int MD5_Final(void *input, MD5_CTX *md5);
+int SHA1_Init(SHA_CTX *md5);
+int SHA1_Update(SHA_CTX *sha, void *input, unsigned long sz);
+int SHA1_Final(void *input, SHA_CTX *sha);