summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/src/cyassl-compat.c
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/src/cyassl-compat.c
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/src/cyassl-compat.c')
-rw-r--r--libs/luci-lib-nixio/src/cyassl-compat.c31
1 files changed, 31 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/src/cyassl-compat.c b/libs/luci-lib-nixio/src/cyassl-compat.c
new file mode 100644
index 000000000..a483119ac
--- /dev/null
+++ b/libs/luci-lib-nixio/src/cyassl-compat.c
@@ -0,0 +1,31 @@
+#include "cyassl-compat.h"
+
+int MD5_Init(MD5_CTX *md5) {
+ InitMd5(md5);
+ return 1;
+}
+
+int MD5_Update(MD5_CTX *md5, void *input, unsigned long sz) {
+ Md5Update(md5, input, (word32)sz);
+ return 1;
+}
+
+int MD5_Final(void *input, MD5_CTX *md5) {
+ Md5Final(md5, input);
+ return 1;
+}
+
+int SHA1_Init(SHA_CTX *sha) {
+ InitSha(sha);
+ return 1;
+}
+
+int SHA1_Update(SHA_CTX *sha, void *input, unsigned long sz) {
+ ShaUpdate(sha, input, (word32)sz);
+ return 1;
+}
+
+int SHA1_Final(void *input, SHA_CTX *sha) {
+ ShaFinal(sha, input);
+ return 1;
+}