summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua')
-rw-r--r--libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua17
1 files changed, 17 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua b/libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua
new file mode 100644
index 0000000000..a08b48d680
--- /dev/null
+++ b/libs/luci-lib-nixio/docsrc/nixio.CryptoHash.lua
@@ -0,0 +1,17 @@
+--- Cryptographical Hash and HMAC object.
+-- @cstyle instance
+module "nixio.CryptoHash"
+
+--- Add another chunk of data to be hashed.
+-- @class function
+-- @name CryptoHash.update
+-- @param chunk Chunk of data
+-- @return CryptoHash object (self)
+
+--- Finalize the hash and return the digest.
+-- @class function
+-- @name CryptoHash.final
+-- @usage You cannot call update on a hash object that was already finalized
+-- you can however call final multiple times to get the digest.
+-- @return hexdigest
+-- @return buffer containing binary digest \ No newline at end of file