summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/www/lua/env.lua
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/www/lua/env.lua
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/www/lua/env.lua')
-rw-r--r--libs/luci-lib-nixio/axTLS/www/lua/env.lua26
1 files changed, 26 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/www/lua/env.lua b/libs/luci-lib-nixio/axTLS/www/lua/env.lua
new file mode 100644
index 000000000..c4298477b
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/www/lua/env.lua
@@ -0,0 +1,26 @@
+-- This file should be executed before any script in this directory
+-- according to the configuration (cgilua/conf.lua).
+
+pcall (cgilua.enablesession)
+
+local put, mkurlpath = cgilua.put, cgilua.mkurlpath
+
+cgilua.addclosefunction (function ()
+ put [[
+<p>
+<small>
+<a href="test_main.html">Main</a>]]
+ for _, test in {
+ { "Get", "test_main.lua", {ab = "cd", ef = "gh"} },
+ { "Cookies", "test_cookies.lua", },
+ { "FileSystem", "test_fs.lua", },
+ { "Libraries", "test_lib.lua", },
+ { "Session", "test_session.lua", },
+ { "Variables", "test_variables.lp", },
+ } do
+ put (string.format (' &middot; <a href="%s">%s</a>',
+ mkurlpath (test[2], test[3]), test[1]))
+ end
+ put [[
+</small>]]
+end)