summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/samples/Config.in
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/samples/Config.in
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/samples/Config.in')
-rw-r--r--libs/luci-lib-nixio/axTLS/samples/Config.in63
1 files changed, 63 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/samples/Config.in b/libs/luci-lib-nixio/axTLS/samples/Config.in
new file mode 100644
index 000000000..ecad25eeb
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/samples/Config.in
@@ -0,0 +1,63 @@
+#
+# For a description of the syntax of this configuration file,
+# see scripts/config/Kconfig-language.txt
+#
+menu "Samples"
+
+config CONFIG_SAMPLES
+ bool "Create Samples"
+ default y
+ help
+ axTLS contains various sample code.
+
+ Select Y here if you want to build the various samples.
+
+config CONFIG_C_SAMPLES
+ bool "axssl - C version"
+ default y
+ depends on CONFIG_SAMPLES
+ help
+ Build the "C" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+
+config CONFIG_CSHARP_SAMPLES
+ bool "axssl - C# version"
+ default y
+ depends on CONFIG_SAMPLES && CONFIG_CSHARP_BINDINGS
+ help
+ Build the "C#" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+
+config CONFIG_VBNET_SAMPLES
+ bool "axssl - VB.NET version"
+ default y
+ depends on CONFIG_SAMPLES && CONFIG_VBNET_BINDINGS
+ help
+ Build the "VB.NET" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+
+config CONFIG_JAVA_SAMPLES
+ bool "axssl - Java version"
+ default y
+ depends on CONFIG_SAMPLES && CONFIG_JAVA_BINDINGS
+ help
+ Build the "Java" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+
+config CONFIG_PERL_SAMPLES
+ bool "axssl - Perl version"
+ default y
+ depends on CONFIG_SAMPLES && CONFIG_PERL_BINDINGS
+ help
+ Build the "Perl" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+
+config CONFIG_LUA_SAMPLES
+ bool "axssl - Lua version"
+ default y
+ depends on CONFIG_SAMPLES && CONFIG_LUA_BINDINGS
+ help
+ Build the "Lua" version of axssl. The features enabled are very
+ dependent on the build mode ('full' mode will give all features).
+endmenu
+