summaryrefslogtreecommitdiffhomepage
path: root/libs/luci-lib-nixio/axTLS/config/makefile.post
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2014-12-03 15:17:05 +0100
committerJo-Philipp Wich <jow@openwrt.org>2015-01-08 16:26:20 +0100
commit1bb4822dca6113f73e3bc89e2acf15935e6f8e92 (patch)
tree35e16f100466e4e00657199b38bb3d87d52bf73f /libs/luci-lib-nixio/axTLS/config/makefile.post
parent9edd0e46c3f880727738ce8ca6ff1c8b85f99ef4 (diff)
Rework LuCI build system
* Rename subdirectories to their repective OpenWrt package names * Make each LuCI module its own standalone package * Deploy a shared luci.mk which is used by each module Makefile Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'libs/luci-lib-nixio/axTLS/config/makefile.post')
-rw-r--r--libs/luci-lib-nixio/axTLS/config/makefile.post19
1 files changed, 19 insertions, 0 deletions
diff --git a/libs/luci-lib-nixio/axTLS/config/makefile.post b/libs/luci-lib-nixio/axTLS/config/makefile.post
new file mode 100644
index 0000000000..033981c4d1
--- /dev/null
+++ b/libs/luci-lib-nixio/axTLS/config/makefile.post
@@ -0,0 +1,19 @@
+
+ifneq ($(MAKECMDGOALS), clean)
+ifndef CONFIG_PLATFORM_WIN32
+ifndef CONFIG_PLATFORM_SOLARIS
+# do dependencies
+-include .depend
+all : .depend
+.depend: $(wildcard *.c)
+ @$(CC) $(CFLAGS) -MM $^ > $@
+endif # 'not' solaris
+endif # 'not' win32
+
+ifdef CONFIG_PLATFORM_WIN32
+OBJ:=$(OBJ:.o=.obj)
+%.obj : %.c
+ $(CC) $(CFLAGS) $<
+endif # win32
+
+endif # end of 'not' clean