summaryrefslogtreecommitdiffhomepage
path: root/libs/luaneightbl/Makefile
diff options
context:
space:
mode:
authorPatrick Grimm <patrick@lunatiki.de>2013-07-07 12:45:59 +0000
committerPatrick Grimm <patrick@lunatiki.de>2013-07-07 12:45:59 +0000
commit54001e307e135cf6080443567184e000336fc548 (patch)
tree3f4acedb817b5faa958da45299a9cd2b72639da2 /libs/luaneightbl/Makefile
parentd946f2931e2c26cfbe3c0848cb572867dd67bfef (diff)
add luaneightbl: this is an arp replacement for ipv6. neightbl.get(wlan0) return ip,mac table this can use in a for loop "for ip,mac in pairs(t) do" Thanx Cyrus
Diffstat (limited to 'libs/luaneightbl/Makefile')
-rw-r--r--libs/luaneightbl/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/libs/luaneightbl/Makefile b/libs/luaneightbl/Makefile
new file mode 100644
index 000000000..dc2db6740
--- /dev/null
+++ b/libs/luaneightbl/Makefile
@@ -0,0 +1,24 @@
+ifneq (,$(wildcard ../../build/config.mk))
+include ../../build/config.mk
+include ../../build/module.mk
+include ../../build/gccconfig.mk
+else
+include standalone.mk
+endif
+
+NEIGHTBL_CFLAGS = $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $(WFLAGS)
+
+NEIGHTBL_OBJ = src/neightbl.o
+NEIGHTBL_LIB = src/neightbl.so
+
+%.o: %.c
+ $(CC) $(NEIGHTBL_CFLAGS) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: $(NEIGHTBL_OBJ)
+ $(LINK) $(SHLIB_FLAGS) -o $(NEIGHTBL_LIB) $(NEIGHTBL_OBJ)
+ mkdir -p dist$(LUA_LIBRARYDIR)
+ cp $(NEIGHTBL_LIB) dist$(LUA_LIBRARYDIR)/
+
+clean: luaclean
+ rm -f src/*.o src/*.so src/*.a src/*.dll
+