summaryrefslogtreecommitdiffhomepage
path: root/libs/httpd/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-16 19:47:57 +0000
committerSteven Barth <steven@midlink.org>2008-06-16 19:47:57 +0000
commitdfe85d7e518cc35a55e372b0ac31345788a486a8 (patch)
tree5651cf8017bbb58f2da9eb93ca2013236b30eac6 /libs/httpd/Makefile
parent77da39e7762f7494399e7bad88709764cd6d8f44 (diff)
* Added preliminary HTTPD construct
Diffstat (limited to 'libs/httpd/Makefile')
-rw-r--r--libs/httpd/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/libs/httpd/Makefile b/libs/httpd/Makefile
new file mode 100644
index 000000000..ee1a40ea8
--- /dev/null
+++ b/libs/httpd/Makefile
@@ -0,0 +1,13 @@
+include ../../build/module.mk
+include ../../build/config.mk
+include ../../build/gccconfig.mk
+
+%.o: %.c
+ $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: src/fastindex.o
+ mkdir -p dist$(LUCI_LIBRARYDIR)
+ $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_LIBRARYDIR)/fastindex.so src/fastindex.o $(LUA_SHLIBS)
+
+clean:
+ rm -f src/*.o