summaryrefslogtreecommitdiffhomepage
path: root/libs/fastindex/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-02 15:35:22 +0000
committerSteven Barth <steven@midlink.org>2008-06-02 15:35:22 +0000
commit088bc4628bbf6bdc005adf8054549e3798306f74 (patch)
tree40837ad404f07829a3d224929996ad05a9580d35 /libs/fastindex/Makefile
parentdc157c4dda60288fff57400144c1b2c7f6ca6683 (diff)
add the fastindex module
Diffstat (limited to 'libs/fastindex/Makefile')
-rw-r--r--libs/fastindex/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/libs/fastindex/Makefile b/libs/fastindex/Makefile
new file mode 100644
index 000000000..560a35283
--- /dev/null
+++ b/libs/fastindex/Makefile
@@ -0,0 +1,12 @@
+include ../../build/config.mk
+include ../../build/gccconfig.mk
+
+%.o: %.c
+ $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: src/fastindex.o
+ mkdir -p dist/usr/lib/lua/luci
+ $(LINK) $(SHLIB_FLAGS) -o dist/usr/lib/lua/luci/fastindex.so src/fastindex.o $(LUA_SHLIBS)
+
+clean:
+ rm -f src/*.o