summaryrefslogtreecommitdiffhomepage
path: root/libs/core/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-11-20 15:15:50 +0000
committerSteven Barth <steven@midlink.org>2008-11-20 15:15:50 +0000
commit9a203c52dd9bcbdb11bc86b99ea61027eec7cc26 (patch)
tree07e1cd233a780957b957f2912a1815dbb70d914a /libs/core/Makefile
parent40639695cba1c2169cefff827178dd81c47cfbc1 (diff)
Integrate core C implementation
Diffstat (limited to 'libs/core/Makefile')
-rw-r--r--libs/core/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/libs/core/Makefile b/libs/core/Makefile
index f7fac7740e..7c9b3d794f 100644
--- a/libs/core/Makefile
+++ b/libs/core/Makefile
@@ -1,2 +1,12 @@
include ../../build/config.mk
include ../../build/module.mk
+
+%.o: %.c
+ $(COMPILE) $(LUA_CFLAGS) $(FPIC) -c -o $@ $<
+
+compile: src/luci_cutil.o
+ mkdir -p dist$(LUCI_LIBRARYDIR)
+ $(LINK) $(SHLIB_FLAGS) -o dist$(LUCI_LIBRARYDIR)/cutil.so src/luci_cutil.o
+
+clean: luaclean
+ rm src/*.o \ No newline at end of file