summaryrefslogtreecommitdiffhomepage
path: root/core
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-11 19:16:16 +0000
committerSteven Barth <steven@midlink.org>2008-04-11 19:16:16 +0000
commit120717c6ec1bd64dbf5606fe1edcc207aebcc560 (patch)
treeae1dc987ae2840bfd5a195689abbb6e99c90f7b6 /core
parentc3755056f8e4871f96a21a17b20c5a391b7c3b30 (diff)
* Fixing Makefiles
Diffstat (limited to 'core')
-rw-r--r--core/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/core/Makefile b/core/Makefile
index 7db8ddb4a..458396357 100644
--- a/core/Makefile
+++ b/core/Makefile
@@ -21,8 +21,8 @@ all: compile
depends:
mkdir -p $(OUTDIRS)
- for i in $(CPFILES); do [ -f "$$i" ] && (i=$$(echo $$i | cut -d/ -f2-); \
- mkdir -p dist/$$(dirname $$i); cp src/$$i dist/$$i); done
+ for i in $(CPFILES); do if [ -f "$i" ]; then i=$$(echo $$i | cut -d/ -f2-); \
+ mkdir -p dist/$$(dirname $$i); cp src/$$i dist/$$i; fi; done
compile: depends
$(LUAC) $(LUAC_OPTIONS) -o dist/$(OUTFILE) $(INFILES)