summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-28 20:55:05 +0000
committerSteven Barth <steven@midlink.org>2008-05-28 20:55:05 +0000
commitc326b0fa716c457ea7842d2f7c9c13eb3957f0bb (patch)
tree8f1adaa51fb596ce9974229b06d7bfcca14ed7ce /contrib
parente9ae878ce679c48c71c67a885c3a62cf71aa584b (diff)
* Fixed OpenWRT Makefile
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile33
1 files changed, 29 insertions, 4 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d1995f330..e77c41e66 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -28,7 +28,7 @@ endef
define Build/Compile
- for i in '$(PKG_SELECTED_MODULES)'; do $(MAKE) -C$(PKG_BUILD_DIR)/$$i build LUA_TARGET=$(LUA_TARGET); done
+ for i in $(PKG_SELECTED_MODULES); do $(MAKE) -C$(PKG_BUILD_DIR)/$$$$i build LUA_TARGET=$(LUA_TARGET); done
endef
### Templates ###
@@ -49,6 +49,12 @@ define Package/luci/fftemplate
DEPENDS:=+luci-mod-freifunk
endef
+define Package/luci/thtemplate
+ $(call Package/luci/libtemplate)
+ SUBMENU:=LuCI - Themes
+ DEPENDS:=+luci-web
+endef
+
define Package/luci/webtemplate
$(call Package/luci/libtemplate)
SUBMENU:=LuCI - Webinterface Components
@@ -98,7 +104,6 @@ endef
define Package/luci-web/install
$(call Package/luci/install/template,$(1),libs/web)
- $(call Package/luci/install/template,$(1),themes/fledermaus)
endef
@@ -157,7 +162,7 @@ endef
define Package/luci-mod-admin-core
$(call Package/luci/webtemplate)
- DEPENDS+=+luci-web +luci-cbi
+ DEPENDS+=+luci-web +luci-cbi +luci-theme-fledermaus
TITLE:=Administration module
endef
@@ -272,7 +277,18 @@ define Package/luci-sgi-webuci/install
$(call Package/luci/install/template,$(1),libs/sgi-webuci)
endef
-### Compile Templates ###
+### Templates ###
+define Package/luci-theme-fledermaus
+ $(call Package/luci/thtemplate)
+ TITLE:=Fledermaus (default)
+endef
+
+define Package/luci-theme-fledermaus/install
+ $(call Package/luci/install/template,$(1),themes/fledermaus)
+endef
+
+
+### Compile ###
ifneq ($(CONFIG_PACKAGE_luci-core),)
PKG_SELECTED_MODULES+=libs/core
endif
@@ -303,6 +319,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-app-ffwizard-leipzig),)
PKG_SELECTED_MODULES+=applications/luci-ffwizard-leipzig
endif
+ifneq ($(CONFIG_PACKAGE_luci-app-firewall),)
+ PKG_SELECTED_MODULES+=applications/luci-fw
+endif
ifneq ($(CONFIG_PACKAGE_luci-app-splash),)
PKG_SELECTED_MODULES+=applications/luci-splash
endif
@@ -317,6 +336,10 @@ ifneq ($(CONFIG_PACKAGE_luci-sgi-webuci),)
PKG_SELECTED_MODULES+=libs/sgi-webuci
endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-fledermaus),)
+ PKG_SELECTED_MODULES+=themes/fledermaus
+endif
+
$(eval $(call BuildPackage,luci-core))
$(eval $(call BuildPackage,luci-cbi))
@@ -336,3 +359,5 @@ $(eval $(call BuildPackage,luci-app-statistics))
$(eval $(call BuildPackage,luci-sgi-haserl))
$(eval $(call BuildPackage,luci-sgi-webuci))
+
+$(eval $(call BuildPackage,luci-theme-fledermaus))