summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-09-17 22:26:41 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-09-17 22:26:41 +0000
commitc10ce06b6b50db9d8cf3d7059de979cb468a44aa (patch)
treec43e4cd87e82c1c559243fca73dbf6333b0ed4e2 /contrib
parent8b53a27b5cf7e923fcf563989e4a9271d804abbc (diff)
* luci/contrib: add missing definitions for p910nd package in trunk makefile
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 8a8418dcb..2a67b33dd 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -458,6 +458,16 @@ define Package/luci-app-uvc_streamer/install
endef
+define Package/luci-app-p910nd
+ $(call Package/luci/webtemplate)
+ DEPENDS+=+luci-admin-full +p910nd
+ TITLE:=p910nd - Printer server module
+endef
+
+define Package/luci-app-p910nd/install
+ $(call Package/luci/install/template,$(1),applications/luci-p910nd)
+endef
+
### Server Gateway Interfaces ###
@@ -650,6 +660,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-app-uvc_streamer),)
PKG_SELECTED_MODULES+=applications/luci-uvc_streamer
endif
+ifneq ($(CONFIG_PACKAGE_luci-app-p910nd),)
+ PKG_SELECTED_MODULES+=applications/luci-p910nd
+endif
ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -727,6 +740,7 @@ $(eval $(call BuildPackage,luci-app-ntpc))
$(eval $(call BuildPackage,luci-app-ddns))
$(eval $(call BuildPackage,luci-app-samba))
$(eval $(call BuildPackage,luci-app-uvc_streamer))
+$(eval $(call BuildPackage,luci-app-p910nd))
$(eval $(call BuildPackage,luci-sgi-cgi))
$(eval $(call BuildPackage,luci-sgi-luci))