summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-28 19:37:43 +0000
committerSteven Barth <steven@midlink.org>2008-05-28 19:37:43 +0000
commit4e53d007bf30dddad1a2e1b44aa55d3ca8671ae4 (patch)
tree69e5a17bb861283f1333f3304b1e8dca16ef3955 /contrib
parent38844ccb3107cd84488ae1cd67fec8e7de833eb4 (diff)
* Reworked Makefiles
* Introduced following targets: build: gccbuild luabuild gccbuild: compile luabuild: luasource||luacompile * Removed requirement for lua-headers respecting lua-only builds * Split compile part of OpenWRT Makefile
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile29
1 files changed, 26 insertions, 3 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index f2a26245d..997b9f901 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -25,11 +25,12 @@ include $(INCLUDE_DIR)/package.mk
define Build/Configure
endef
-define Build/Compile
- $(MAKE) -C$(PKG_BUILD_DIR) build LUA_TARGET=$(LUA_TARGET)
+define Package/luci/compiletpl
+ ifneq ($(CONFIG_PACKAGE_$(1)),)
+ $(MAKE) -C$(PKG_BUILD_DIR)/$(2) build LUA_TARGET=$(LUA_TARGET)
+ endif
endef
-
### Templates ###
define Package/luci/libtemplate
@@ -115,6 +116,8 @@ define Package/luci-ff-halle
endef
define Package/luci-ff-halle/install
+ $(call Package/luci/install/template,$(1),applications/community-halle)
+ $(CP) -a ./ipkg/luci-ff-halle.postinst $(1)/CONTROL/postinst
endef
@@ -270,6 +273,26 @@ define Package/luci-sgi-webuci/install
endef
+define Build/Compile
+ $(call Package/luci/compiletpl,luci-core,libs/core)
+ $(call Package/luci/compiletpl,luci-cbi,libs/cbi)
+ $(call Package/luci/compiletpl,luci-web,libs/web)
+
+ $(call Package/luci/compiletpl,luci-ff-halle,applications/community-halle)
+ $(call Package/luci/compiletpl,luci-ff-leipzig,applications/community-leipzig)
+ $(call Package/luci/compiletpl,luci-ff-hannover,applications/community-hannover)
+
+ $(call Package/luci/compiletpl,luci-mod-admin-core,modules/admin-core)
+ $(call Package/luci/compiletpl,luci-mod-freifunk,modules/freifunk)
+
+ $(call Package/luci/compiletpl,luci-app-ffwizard-leipzig,applications/luci-ffwizard-leipzig)
+ $(call Package/luci/compiletpl,luci-app-firewall,applications/luci-fw)
+ $(call Package/luci/compiletpl,luci-app-splash,applications/luci-splash)
+ $(call Package/luci/compiletpl,luci-app-statistics,applications/luci-statistics)
+
+ $(call Package/luci/compiletpl,luci-sgi-haserl,libs/sgi-haserl)
+ $(call Package/luci/compiletpl,luci-sgi-webuci,libs/sgi-webuci)
+endef
$(eval $(call BuildPackage,luci-core))