summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-08-11 16:58:45 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-08-11 16:58:45 +0000
commit4e26d886eb498abc2655c89eae10983a507b7606 (patch)
tree83bbceda534f7a6bece88964e36c0526d279a169 /contrib
parent64541eda089848a84ffed7e73057fed22c6f125c (diff)
* luci/contrib: add openwrt.org light theme to Makefile
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 82cc490f5..d25878fe0 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -529,6 +529,16 @@ define Package/luci-theme-openwrt/install
$(call Package/luci/install/template,$(1),themes/openwrt.org)
endef
+define Package/luci-theme-openwrtlight
+ $(call Package/luci/thtemplate)
+ TITLE:=OpenWRT.org - light variant without images
+endef
+
+define Package/luci-theme-openwrtlight/install
+ $(call Package/luci/install/template,$(1),themes/openwrt-light)
+endef
+
+
### Translations ###
define Package/luci-i18n-german
$(call Package/luci/i18ntemplate)
@@ -669,6 +679,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
PKG_SELECTED_MODULES+=themes/openwrt.org
endif
+ifneq ($(CONFIG_PACKAGE_luci-theme-openwrtlight),)
+ PKG_SELECTED_MODULES+=themes/openwrt-light
+endif
ifneq ($(CONFIG_PACKAGE_luci-i18n-german),)
PKG_SELECTED_MODULES+=i18n/german
@@ -729,6 +742,7 @@ $(eval $(call BuildPackage,luci-sgi-webuci))
$(eval $(call BuildPackage,luci-theme-fledermaus))
$(eval $(call BuildPackage,luci-theme-openwrt))
+$(eval $(call BuildPackage,luci-theme-openwrtlight))
$(eval $(call BuildPackage,luci-i18n-german))
$(eval $(call BuildPackage,luci-i18n-english))