summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2012-09-20 02:16:51 +0000
committerDaniel Golle <daniel@makrotopia.org>2012-09-20 02:16:51 +0000
commit1dbb1da4d9a4ca24d92fe0fdc78e90ce0261e450 (patch)
tree5c0afcc8e66675c76378e57c392d35bf352cda9a /contrib
parent45d812dbb7b6374cd4188925661b74723cef91a7 (diff)
modules: add failsafe module
The failsafe module adds a minimal web-interface which is intended to run on a very compact initramfs-based image intended only for flashing firmware onto a device. This can be used as part of an installation method or reside in a small partition on the device flash which can be booted in case the checksum-test of the main kernel or rootfs fails. Signed-off-by: Daniel Golle <dgolle@allnet.de>
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d3b0cc7b3..9c0ca745e 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -280,6 +280,7 @@ endef
$(eval $(call module,admin-core,Web UI Core module,+luci-lib-web +luci-proto-core +luci-i18n-english))
$(eval $(call module,admin-mini,LuCI Essentials - stripped down and user-friendly,+luci-mod-admin-core @BROKEN))
$(eval $(call module,admin-full,LuCI Administration - full-featured for full control,+luci-mod-admin-core +luci-lib-ipkg))
+$(eval $(call module,failsafe,LuCI Fail-Safe - Fail-Safe sysupgrade module,+luci-mod-admin-core))
$(eval $(call module,rpc,LuCI RPC - JSON-RPC API,+luci-lib-json))
$(eval $(call module,freifunk,LuCI Freifunk module,+luci-mod-admin-full +luci-lib-json +PACKAGE_luci-mod-freifunk:freifunk-firewall +freifunk-common +community-profiles))
$(eval $(call module,niu,NIU - Next Generation Interface,+luci-mod-admin-core @BROKEN))