summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-26 17:55:16 +0000
committerSteven Barth <steven@midlink.org>2008-04-26 17:55:16 +0000
commit035a193353b9ad86621b6b1fa183ccb1e0bd9e3d (patch)
tree65aa5da0b59bc65fa4343bf586b46bceddff754f /contrib
parent22b1721823d705c7318d1eebafdfcdaead3025da (diff)
* Makefile fixes ;-)
* Removed obsolete Haserl patch * Added Client-Splash configuration page
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/ffluci/Makefile3
-rw-r--r--contrib/package/haserl-lua/patches/100-cookie_prefix.patch29
-rw-r--r--contrib/package/luci-splash/Makefile7
3 files changed, 8 insertions, 31 deletions
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index 32afd4a7f..62fe0657a 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -15,6 +15,8 @@ PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+PKG_BUILD_DEPENDS:=lua-luci
+
MAKE_ACTION:=compile LUAC=$(BUILD_DIR_HOST)/lua-luci/luac
include $(INCLUDE_DIR)/package.mk
@@ -23,6 +25,7 @@ define Package/ffluci
SECTION:=admin
CATEGORY:=Administration
TITLE:=FFLuCI
+ SUBMENU:=FFLuCI
DEPENDS:=+luaposix +haserl-lua
MAINTAINER:=Steven Barth <steven-at-midlink-dot-org>
endef
diff --git a/contrib/package/haserl-lua/patches/100-cookie_prefix.patch b/contrib/package/haserl-lua/patches/100-cookie_prefix.patch
deleted file mode 100644
index 0547d9d87..000000000
--- a/contrib/package/haserl-lua/patches/100-cookie_prefix.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- haserl-0.9.23.orig/src/haserl.c 2008-03-18 18:17:55.000000000 +0100
-+++ haserl-0.9.23/src/haserl.c 2008-03-27 16:58:27.000000000 +0100
-@@ -340,7 +340,7 @@
- {
- token++;
- }
-- myputenv (env, token, global.var_prefix);
-+ myputenv (env, token, global.cookie_prefix);
- token = strtok (NULL, ";");
- }
- free (qs);
-@@ -614,6 +614,7 @@
- global.acceptall = FALSE; /* don't allow POST data for GET method */
- global.uploadlist = NULL; /* we don't have any uploaded files */
- global.var_prefix = HASERL_VAR_PREFIX;
-+ global.cookie_prefix = "COOKIE_";
- global.nul_prefix = "";
-
- }
---- haserl-0.9.23.orig/src/haserl.h 2008-01-25 22:11:38.000000000 +0100
-+++ haserl-0.9.23/src/haserl.h 2008-03-27 16:58:18.000000000 +0100
-@@ -10,6 +10,7 @@
- char *uploaddir; /* where we upload to */
- char *uploadhandler; /* a handler for uploads */
- char *var_prefix; /* what name we give to FORM variables */
-+ char *cookie_prefix;
- char *nul_prefix; /* what name we give to environment variables */
- token_t *uploadlist; /* a linked list of pathspecs */
- int debug; /* true if in "debug" mode */
diff --git a/contrib/package/luci-splash/Makefile b/contrib/package/luci-splash/Makefile
index e1e194cbd..eb41fde5d 100644
--- a/contrib/package/luci-splash/Makefile
+++ b/contrib/package/luci-splash/Makefile
@@ -12,11 +12,14 @@ include $(INCLUDE_DIR)/package.mk
define Package/luci-splash
SECTION:=admin
CATEGORY:=Administration
- SUBMENU:=ffluci
- DEPENDS:=+ffluci
+ SUBMENU:=FFLuCI
+ DEPENDS:=+ffluci +iptables-mod-nat
TITLE:=FFLuCI DHCP-Splash
endef
+define Build/Compile
+endef
+
define Package/luci-splash/install
$(INSTALL_DIR) $(1)/usr/lib/luci_splash/htdocs
$(INSTALL_DIR) $(1)/etc/config