summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-04-06 18:23:58 +0000
committerSteven Barth <steven@midlink.org>2008-04-06 18:23:58 +0000
commit98656c6b54cff3a098d89d2b722551def52f6510 (patch)
tree82d94adee5b2aa20b86f03e345dd0464a33eb727 /contrib
parent9e67df179f28e62045d5452134e23bebb9eab72f (diff)
* Cleaning up package definitions and sources to better harmonize with OpenWRT-packages
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package-source/haserl-lua-0.9.23.tar.bz2bin0 -> 100110 bytes
-rw-r--r--contrib/package-source/lua-luci-5.1.3.tar.bz2bin0 -> 175758 bytes
-rw-r--r--contrib/package/haserl-lua/Makefile12
-rw-r--r--contrib/package/lua-luci/Makefile21
4 files changed, 17 insertions, 16 deletions
diff --git a/contrib/package-source/haserl-lua-0.9.23.tar.bz2 b/contrib/package-source/haserl-lua-0.9.23.tar.bz2
new file mode 100644
index 000000000..d48e653f9
--- /dev/null
+++ b/contrib/package-source/haserl-lua-0.9.23.tar.bz2
Binary files differ
diff --git a/contrib/package-source/lua-luci-5.1.3.tar.bz2 b/contrib/package-source/lua-luci-5.1.3.tar.bz2
new file mode 100644
index 000000000..640a71fe8
--- /dev/null
+++ b/contrib/package-source/lua-luci-5.1.3.tar.bz2
Binary files differ
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
index 9b5b198fc..6d2a4f131 100644
--- a/contrib/package/haserl-lua/Makefile
+++ b/contrib/package/haserl-lua/Makefile
@@ -3,18 +3,16 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-#
-# $Id: Makefile 1719 2008-03-24 16:07:38Z Cyrus $
include $(TOPDIR)/rules.mk
-PKG_NAME:=haserl
+PKG_NAME:=haserl-lua
PKG_VERSION:=0.9.23
PKG_RELEASE:=1
-PKG_SOURCE:=haserl-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=@SF/haserl
-PKG_MD5SUM:=31d1f505afe3ba1b351e18612aa57a70
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/
+PKG_MD5SUM:=f3a0f329904791c5662d93638f92bdfd
include $(INCLUDE_DIR)/package.mk
@@ -34,6 +32,8 @@ define Package/haserl-lua/install
$(INSTALL_DIR) $(1)/usr/bin
$(STRIP) $(PKG_BUILD_DIR)/src/haserl
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/haserl $(1)/usr/bin/
+ echo "Replaces: haserl" >> $(1)/CONTROL/control
+ echo "Conflicts: haserl" >> $(1)/CONTROL/control
endef
$(eval $(call BuildPackage,haserl-lua))
diff --git a/contrib/package/lua-luci/Makefile b/contrib/package/lua-luci/Makefile
index b01d3f820..956a9f9ea 100644
--- a/contrib/package/lua-luci/Makefile
+++ b/contrib/package/lua-luci/Makefile
@@ -3,26 +3,21 @@
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
-#
-# $Id: Makefile 10499 2008-02-19 23:40:28Z nico $
include $(TOPDIR)/rules.mk
-PKG_NAME:=lua
+PKG_NAME:=lua-luci
PKG_VERSION:=5.1.3
PKG_RELEASE:=1
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
- http://ftp.gwdg.de/pub/languages/lua/ \
- http://mirrors.dotsrc.org/lua/ \
- http://www.tecgraf.puc-rio.br/lua/ftp/
-PKG_MD5SUM:=a70a8dfaa150e047866dc01a46272599
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/trunk/contrib/package-source/
+PKG_MD5SUM:=98b12c767a5eed92169b01537e988c7f
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
-X_HOST_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)-luci
+X_HOST_DIR:=$(BUILD_DIR_HOST)/$(PKG_NAME)
include $(INCLUDE_DIR)/package.mk
@@ -125,16 +120,22 @@ endef
define Package/liblua-luci/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblua.so.* $(1)/usr/lib/
+ echo "Replaces: liblua" >> $(1)/CONTROL/control
+ echo "Conflicts: liblua" >> $(1)/CONTROL/control
endef
define Package/lua-luci/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lua $(1)/usr/bin/
+ echo "Replaces: lua" >> $(1)/CONTROL/control
+ echo "Conflicts: lua" >> $(1)/CONTROL/control
endef
define Package/luac-luci/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/luac $(1)/usr/bin/
+ echo "Replaces: luac" >> $(1)/CONTROL/control
+ echo "Conflicts: luac" >> $(1)/CONTROL/control
endef
define Package/lua-luci-examples/install