summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-10-07 23:12:27 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-10-07 23:12:27 +0000
commitf6164c6955d6704b587c16f1572c9806c7f11c07 (patch)
tree254875547af06a43aaf6a7622d53eae62c7da4c9 /contrib
parentda2b40c9e3ecbc3e1a231d78606e6193aab5544e (diff)
contrib/uci: apply patch series during host uci build
Diffstat (limited to 'contrib')
-rw-r--r--contrib/uci/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index 19625aa72..98e5ed439 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -23,9 +23,12 @@ $(UCI_FILE):
$(UCI_PATCHDIR)/series:
(cd $(UCI_PATCHDIR); ls *.patch | sort > series)
-$(UCI_DIR)/.prepared: $(UCI_FILE)
+$(UCI_DIR)/.prepared: $(UCI_PATCHDIR)/series $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
+ while read patch; do \
+ patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
+ done < $(UCI_PATCHDIR)/series
touch $@
compile: $(UCI_DIR)/.prepared