summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-11-13 15:18:32 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-11-13 15:18:32 +0000
commitb7a720111d7b8d67f8a25bfbe6f2778f31e91094 (patch)
tree578ff5442c919d429b7df00da58ef44a5cb26870 /contrib
parent2efe49d7584e0f53a53a2c3793b24e6df69f5ab3 (diff)
* luci/contrib: let operate axhttpd in nph mode
Diffstat (limited to 'contrib')
-rw-r--r--contrib/axtls/Makefile2
-rw-r--r--contrib/axtls/patches/004-cgi-nph-mode.patch20
2 files changed, 21 insertions, 1 deletions
diff --git a/contrib/axtls/Makefile b/contrib/axtls/Makefile
index 459a15cc8..b6ede0cf8 100644
--- a/contrib/axtls/Makefile
+++ b/contrib/axtls/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=axtls
PKG_VERSION:=1.2.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_BUILD_DIR=$(BUILD_DIR)/axTLS
PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
diff --git a/contrib/axtls/patches/004-cgi-nph-mode.patch b/contrib/axtls/patches/004-cgi-nph-mode.patch
new file mode 100644
index 000000000..2b6cc5c43
--- /dev/null
+++ b/contrib/axtls/patches/004-cgi-nph-mode.patch
@@ -0,0 +1,20 @@
+--- axTLS/httpd/proc.c 2008-11-13 14:05:02.000000000 +0100
++++ axTLS.new/httpd/proc.c 2008-11-13 16:07:12.000000000 +0100
+@@ -556,13 +556,13 @@
+ int tmp_stdout;
+ #endif
+
+- snprintf(cgienv[0], MAXREQUESTLENGTH,
++ if (cn->reqtype == TYPE_HEAD)
++ {
++ snprintf(cgienv[0], MAXREQUESTLENGTH,
+ HTTP_VERSION" 200 OK\nServer: %s\n%s",
+ server_version, (cn->reqtype == TYPE_HEAD) ? "\n" : "");
+- special_write(cn, cgienv[0], strlen(cgienv[0]));
++ special_write(cn, cgienv[0], strlen(cgienv[0]));
+
+- if (cn->reqtype == TYPE_HEAD)
+- {
+ removeconnection(cn);
+ return;
+ }