summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-22 14:04:03 +0000
committerSteven Barth <steven@midlink.org>2008-05-22 14:04:03 +0000
commit6604399aa8f35d33c53a5e5a1fea765f401aef5e (patch)
treeed818d630634a98a8996a1ba6d10e63bbea17c39 /contrib
parentf738eb786e3d30028310c7bcc447e7e7b63767e0 (diff)
Merge branch 'menu'
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/ffluci/Makefile2
-rw-r--r--contrib/package/lua-luci/patches/200-lua-path.patch47
2 files changed, 35 insertions, 14 deletions
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index ca7540261..34c796e2d 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -5,7 +5,7 @@ PKG_SOURCE_URL:=https://dev.leipzig.freifunk.net/svn/ff-luci/$(PKG_BRANCH)
PKG_REV:=$(shell LC_ALL=C svn info ${PKG_SOURCE_URL} | sed -ne's/^Last Changed Rev: //p')
PKG_NAME:=ffluci
-PKG_VERSION:=0.4+svn$(PKG_REV)
+PKG_VERSION:=0.5+svn$(PKG_REV)
PKG_RELEASE:=1
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
diff --git a/contrib/package/lua-luci/patches/200-lua-path.patch b/contrib/package/lua-luci/patches/200-lua-path.patch
index 62dd00e39..60797e98d 100644
--- a/contrib/package/lua-luci/patches/200-lua-path.patch
+++ b/contrib/package/lua-luci/patches/200-lua-path.patch
@@ -1,15 +1,36 @@
---- b/src/luaconf.h 2008-05-06 20:10:46.000000000 +0200
-+++ a/src/luaconf.h 2008-05-06 20:10:27.000000000 +0200
-@@ -95,9 +95,9 @@
- ".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
-
+diff -ur lua-5.1.3/etc/lua.pc lua-5.1.3-new/etc/lua.pc
+--- lua-5.1.3/etc/lua.pc 2008-01-11 14:12:59.000000000 +0100
++++ lua-5.1.3-new/etc/lua.pc 2008-05-18 22:09:24.000000000 +0200
+@@ -8,7 +8,7 @@
+ R= 5.1.3
+
+ # grep '^INSTALL_.*=' ../Makefile | sed 's/INSTALL_TOP/prefix/'
+-prefix= /usr/local
++prefix= /usr
+ INSTALL_BIN= ${prefix}/bin
+ INSTALL_INC= ${prefix}/include
+ INSTALL_LIB= ${prefix}/lib
+diff -ur lua-5.1.3/Makefile lua-5.1.3-new/Makefile
+--- lua-5.1.3/Makefile 2008-05-18 22:06:55.000000000 +0200
++++ lua-5.1.3-new/Makefile 2008-05-18 22:09:13.000000000 +0200
+@@ -12,7 +12,7 @@
+ # doc directory.) You may want to make these paths consistent with LUA_ROOT,
+ # LUA_LDIR, and LUA_CDIR in luaconf.h (and also with etc/lua.pc).
+ #
+-INSTALL_TOP= /usr/local
++INSTALL_TOP= /usr
+ INSTALL_BIN= $(INSTALL_TOP)/bin
+ INSTALL_INC= $(INSTALL_TOP)/include
+ INSTALL_LIB= $(INSTALL_TOP)/lib
+diff -ur lua-5.1.3/src/luaconf.h lua-5.1.3-new/src/luaconf.h
+--- lua-5.1.3/src/luaconf.h 2008-05-18 22:07:11.000000000 +0200
++++ lua-5.1.3-new/src/luaconf.h 2008-05-18 22:09:50.000000000 +0200
+@@ -95,7 +95,7 @@
+ ".\\?.dll;" LUA_CDIR"?.dll;" LUA_CDIR"loadall.dll"
+
#else
--#define LUA_ROOT "/usr/local/"
--#define LUA_LDIR LUA_ROOT "share/lua/5.1/"
--#define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
-+#define LUA_ROOT "/usr/"
-+#define LUA_LDIR LUA_ROOT "share/lua/"
-+#define LUA_CDIR LUA_ROOT "lib/lua/"
+-#define LUA_ROOT "/usr/local/"
++#define LUA_ROOT "/usr/"
+ #define LUA_LDIR LUA_ROOT "share/lua/5.1/"
+ #define LUA_CDIR LUA_ROOT "lib/lua/5.1/"
#define LUA_PATH_DEFAULT \
- "./?.lua;" LUA_LDIR"?.lua;" LUA_LDIR"?/init.lua;" \
- LUA_CDIR"?.lua;" LUA_CDIR"?/init.lua"