summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-28 15:28:13 +0000
committerSteven Barth <steven@midlink.org>2008-05-28 15:28:13 +0000
commit4365fbe2a373b73af5578d0ed6eddfb2ba9901ef (patch)
treecdc534c74a881b666012a92a645ff22c973a11a7 /contrib
parent776f9957d0376670e9d3e43677dbe3ba19ded193 (diff)
Squashed commit of the following:
commit d45d1757d24d8214f730af1a3401dd2bef4a434f Author: Steven <steven@cyrus.homeunix.org> Date: Wed May 28 17:23:27 2008 +0200 * libs/core: Removed dummymode checks in sys * libs/sgi-webuci: Fixes commit b870e8d345bc8912fd8ab61d463b9d68b924a6f4 Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 15:40:10 2008 +0200 fix path to theme commit e3732926bd98db4cc38de6eb8018cd4e55176699 Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 14:56:03 2008 +0200 set the proper path to the config in dummy mode commit a75aecf46f037c98bd6e49b9e48adb735d76d150 Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 14:50:42 2008 +0200 add some dummy mode support commit 12bb39ef606bca6b403cc982213a6597b76dc1b3 Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 14:41:56 2008 +0200 normalize paths commit 7aaad1103fd2bdc75aca158baa6ef191f9a961c6 Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 14:27:26 2008 +0200 add missing require statement commit 5766274bd2511b00c42b474aeeeb3efaca6ded9b Author: Felix Fietkau <nbd@openwrt.org> Date: Wed May 28 14:19:54 2008 +0200 add optional luaposix package (patched for darwin support) commit 9e257a76d03722fc0ce8312aa9952641b21424bd Author: Felix Fietkau <nbd@openwrt.org> Date: Tue May 27 20:21:59 2008 +0200 add missing files, more integration for the boa plugin, fix path to lua modules commit dacc1a98ec946975fcb19f87076dfa7db865fca6 Author: Felix Fietkau <nbd@openwrt.org> Date: Tue May 27 19:42:37 2008 +0200 use "compile" instead of "source" and rename the old version of compile to "compile-all" commit eb14777c4fee1eb5740aba1e5603e481320da7b1 Author: Felix Fietkau <nbd@openwrt.org> Date: Tue May 27 19:41:59 2008 +0200 more boa integration commit df0afb965bf0a987b653e9d0acadf3151179a596 Author: Felix Fietkau <nbd@openwrt.org> Date: Tue May 27 18:33:42 2008 +0200 build boa and the webuci.so plugin along with sgi-webuci commit 878161dabf32066631103d199e2cbaf3f5a7fb07 Author: Felix Fietkau <nbd@openwrt.org> Date: Tue May 27 18:03:16 2008 +0200 add .gitignore
Diffstat (limited to 'contrib')
-rw-r--r--contrib/luaposix/.gitignore2
-rw-r--r--contrib/luaposix/Makefile43
-rw-r--r--contrib/luaposix/patches/100-darwin_compile.patch27
3 files changed, 72 insertions, 0 deletions
diff --git a/contrib/luaposix/.gitignore b/contrib/luaposix/.gitignore
new file mode 100644
index 000000000..c900421f8
--- /dev/null
+++ b/contrib/luaposix/.gitignore
@@ -0,0 +1,2 @@
+luaposix-*
+patches/series
diff --git a/contrib/luaposix/Makefile b/contrib/luaposix/Makefile
new file mode 100644
index 000000000..4f16b5362
--- /dev/null
+++ b/contrib/luaposix/Makefile
@@ -0,0 +1,43 @@
+include ../../build/config.mk
+
+LUAPOSIX_VERSION = 5.1.2
+LUAPOSIX_SITE = http://luaforge.net/frs/download.php/3063/
+LUAPOSIX_DIR = luaposix-$(LUAPOSIX_VERSION)
+LUAPOSIX_FILE = $(LUAPOSIX_DIR).tar.gz
+LUAPOSIX_URL = $(LUAPOSIX_SITE)/$(LUAPOSIX_FILE)
+LUAPOSIX_PATCHDIR = patches
+
+all: compile
+
+$(LUAPOSIX_FILE):
+ wget -O $@ $(LUAPOSIX_URL) || rm -f $@
+
+$(LUAPOSIX_PATCHDIR)/series:
+ (cd $(LUAPOSIX_PATCHDIR); ls *.patch | sort > series)
+
+$(LUAPOSIX_DIR)/.prepared: $(LUAPOSIX_FILE)
+ rm -rf $(LUAPOSIX_DIR)
+ tar xvfz $(LUAPOSIX_FILE)
+ ln -s ../$(LUAPOSIX_PATCHDIR) $(LUAPOSIX_DIR)/patches
+ touch $@
+
+$(LUAPOSIX_DIR)/.patched: $(LUAPOSIX_DIR)/.prepared $(LUAPOSIX_PATCHDIR)/series
+ (cd $(LUAPOSIX_DIR); \
+ if [ -x "$$(which quilt 2>/dev/null)" ]; then \
+ quilt push -a; \
+ else \
+ cat patches/*.patch | patch -p1; \
+ fi; \
+ )
+ touch $@
+
+compile: $(LUAPOSIX_DIR)/.patched
+ $(MAKE) -C $(LUAPOSIX_DIR) CC=$(CC) CFLAGS="$(CFLAGS)" OS="$(OS)"
+ mkdir -p dist/usr/lib/lua
+ cp $(LUAPOSIX_DIR)/posix.so dist/usr/lib/lua/
+
+compile-all: compile
+
+clean:
+ rm -rf $(LUAPOSIX_DIR) $(LUAPOSIX_FILE)
+ rm -f $(LUAPOSIX_PATCHDIR)/series
diff --git a/contrib/luaposix/patches/100-darwin_compile.patch b/contrib/luaposix/patches/100-darwin_compile.patch
new file mode 100644
index 000000000..07943acab
--- /dev/null
+++ b/contrib/luaposix/patches/100-darwin_compile.patch
@@ -0,0 +1,27 @@
+Index: luaposix-5.1.2/Makefile
+===================================================================
+--- luaposix-5.1.2.orig/Makefile 2008-01-29 14:49:27.000000000 +0100
++++ luaposix-5.1.2/Makefile 2008-05-28 14:15:30.000000000 +0200
+@@ -34,6 +34,13 @@
+
+ T= $(MYLIB).so
+
++OS=$(shell uname)
++ifeq ($(OS),Darwin)
++ LDFLAGS_SHARED=-bundle -undefined dynamic_lookup
++else
++ LDFLAGS_SHARED=-shared
++endif
++
+ # targets
+ phony += all
+ all: $T
+@@ -43,7 +50,7 @@
+ $(LUA) test.lua
+
+ $T: $(OBJS)
+- $(CC) $(LDFLAGS) -o $@ -shared $(OBJS)
++ $(CC) $(LDFLAGS) -o $@ $(LDFLAGS_SHARED) $(OBJS)
+
+ $(OBJS): modemuncher.c
+