summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-01 12:47:05 +0000
committerSteven Barth <steven@midlink.org>2008-06-01 12:47:05 +0000
commit1e7ad0141d49a0b332acf0bfce541f8f501f918e (patch)
tree3cb6796d5eff56bfe0245a4d3425682b9dbff2c4 /contrib
parent91cee1420033e8f8f677544556c127df415e43bc (diff)
* Added initial German Translation stub
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index ef9fef39e..81a7796aa 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -324,6 +324,16 @@ define Package/luci-theme-openwrt/install
endef
### Translations ###
+define Package/luci-i18n-german
+ $(call Package/luci/i18ntemplate)
+ TITLE:=German
+endef
+
+define Package/luci-i18n-german/install
+ $(call Package/luci/install/template,$(1),i18n/german)
+endef
+
+
define Package/luci-i18n-english
$(call Package/luci/i18ntemplate)
TITLE:=English (incomplete)
@@ -390,6 +400,9 @@ ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
PKG_SELECTED_MODULES+=themes/openwrt.org
endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-german),)
+ PKG_SELECTED_MODULES+=i18n/german
+endif
ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
PKG_SELECTED_MODULES+=i18n/english
endif
@@ -417,4 +430,5 @@ $(eval $(call BuildPackage,luci-sgi-webuci))
$(eval $(call BuildPackage,luci-theme-fledermaus))
$(eval $(call BuildPackage,luci-theme-openwrt))
+$(eval $(call BuildPackage,luci-i18n-german))
$(eval $(call BuildPackage,luci-i18n-english))