summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-04-21 22:57:07 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-04-21 22:57:07 +0000
commitf375c498f2058b9d8244a628ca78ef5110b2be79 (patch)
tree55f4ae37fb1aeee0bd45a2f8d6dab6aae41d9a6a /contrib
parent34b3ae2a428f75165001dc0ef19cd33bc7f2323a (diff)
applications: add luci-vnstat, frontend for the VnStat traffic monitor
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 9d4d84e9e..55c21a5a8 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -788,6 +788,17 @@ define Package/luci-app-wol/install
$(call Package/luci/install/template,$(1),applications/luci-wol)
endef
+define Package/luci-app-vnstat
+ $(call Package/luci/webtemplate)
+ TITLE:=LuCI Support for VnStat
+ DEPENDS+=+luci-admin-core +PACKAGE_luci-app-vnstat:vnstat \
+ +PACKAGE_luci-app-vnstat:vnstati
+endef
+
+define Package/luci-app-vnstat/install
+ $(call Package/luci/install/template,$(1),applications/luci-vnstat)
+endef
+
### Server Gateway Interfaces ###
@@ -1215,6 +1226,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-app-wol),)
PKG_SELECTED_MODULES+=applications/luci-wol
endif
+ifneq ($(CONFIG_PACKAGE_luci-app-vnstat),)
+ PKG_SELECTED_MODULES+=applications/luci-vnstat
+endif
ifneq ($(CONFIG_PACKAGE_luci-sgi-cgi),)
@@ -1351,6 +1365,7 @@ $(eval $(call BuildPackage,luci-app-openvpn))
$(eval $(call BuildPackage,luci-app-p2pblock))
$(eval $(call BuildPackage,luci-app-multiwan))
$(eval $(call BuildPackage,luci-app-wol))
+$(eval $(call BuildPackage,luci-app-vnstat))
$(eval $(call BuildPackage,luci-sgi-cgi))
$(eval $(call BuildPackage,luci-sgi-uhttpd))