summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2009-05-28 13:50:00 +0000
committerSteven Barth <steven@midlink.org>2009-05-28 13:50:00 +0000
commit20d2e99010f067cd45a7bcfa93fe10862882b3a8 (patch)
treecbd1efa9828a6b1f3fa35a08746c9378477f30c7 /contrib
parentd0bb8964dd9690d7b3ae423c598e95f7fb81ae99 (diff)
nixio: Rework TLS support, added support for CyaSSL
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/cyassl/Makefile58
-rw-r--r--contrib/package/luci/Makefile7
2 files changed, 65 insertions, 0 deletions
diff --git a/contrib/package/cyassl/Makefile b/contrib/package/cyassl/Makefile
new file mode 100644
index 000000000..416e93366
--- /dev/null
+++ b/contrib/package/cyassl/Makefile
@@ -0,0 +1,58 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_BASENAME:=cyassl
+PKG_NAME:=$(PKG_BASENAME)-luci
+PKG_VERSION:=1.0.3
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
+PKG_SOURCE_URL:=http://www.yassl.com/
+PKG_MD5SUM:=e9e85a2d78cd535a049e4acce786e42d
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)/$(PKG_BASENAME)-$(PKG_VERSION)
+PKG_UNPACK=unzip -d $(BUILD_DIR)/$(PKG_NAME) $(DL_DIR)/$(PKG_SOURCE)
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/cyassl-luci/Default
+ TITLE:=CyaSSL (LuCI embedded flavor)
+ URL:=http://www.yassl.com/
+endef
+
+define Package/libcyassl-luci
+ $(call Package/cyassl-luci/Default)
+ SECTION:=libs
+ SUBMENU:=SSL
+ CATEGORY:=Libraries
+ TITLE+= (library)
+endef
+
+define Package/libcyassl-luci/description
+ CyaSSL is an SSL library optimized for small footprint, both on disk and for memory use.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += --without-zlib --enable-fastmath
+
+define Build/InstallDev
+ $(INSTALL_DIR) $(1)/usr/include/ctaocrypt
+ $(CP) $(PKG_BUILD_DIR)/ctaocrypt/include/*.h $(1)/usr/include/ctaocrypt
+
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/src/.libs/libcyassl.{a,so*} $(1)/usr/lib/
+ $(CP) $(PKG_BUILD_DIR)/src/libcyassl.la $(1)/usr/lib/
+endef
+
+define Package/libcyassl-luci/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_BUILD_DIR)/src/.libs/libcyassl.so* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libcyassl-luci))
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 2e7e7a567..4fced4637 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -266,6 +266,10 @@ define Package/luci-nixio/config
select PACKAGE_dropbear
select PACKAGE_dropbearconvert
+ config PACKAGE_luci-nixio_cyassl
+ bool "CyaSSL"
+ select PACKAGE_libcyassl-luci
+
config PACKAGE_luci-nixio_openssl
bool "OpenSSL"
select PACKAGE_libopenssl
@@ -276,6 +280,9 @@ ifneq ($(CONFIG_PACKAGE_luci-nixio_openssl),)
NIXIO_TLS:=openssl
endif
+ifneq ($(CONFIG_PACKAGE_luci-nixio_cyassl),)
+ NIXIO_TLS:=cyassl
+endif
define Package/luci-sys
$(call Package/luci/libtemplate)