summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-05-25 20:49:10 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-05-25 20:49:10 +0000
commite207fce586ba5d5b515b92f0f3347aa750d507f9 (patch)
tree6440c9108427b1d764ec2146978133300fa6e073 /contrib
parentbf907eafda47648257d4b4a39eeaf21b9eddec0c (diff)
* luci/contrib: added statistics to makefile
Diffstat (limited to 'contrib')
-rw-r--r--contrib/package/luci/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index e7d3e9093..2458ebd28 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -185,6 +185,22 @@ define Package/luci-app-splash/install
endef
+define Package/luci-app-statistics
+ $(call Package/luci/template)
+ DEPENDS:=luci +collectd +collectd-mod-rrdtool1 +rrdtool1
+ TITLE:=LuCI Statistics Application (incomplete)
+endef
+
+define Package/luci-app-statistics/conffiles
+/etc/config/luci_statistics
+endef
+
+define Package/luci-app-statistics/install
+ $(call Package/luci/install/template,$(1),applications/luci-statistics)
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
+endef
+
### Server Gateway Interfaces ###
@@ -225,6 +241,7 @@ $(eval $(call BuildPackage,luci-mod-freifunk))
$(eval $(call BuildPackage,luci-app-ffwizard-leipzig))
$(eval $(call BuildPackage,luci-app-firewall))
$(eval $(call BuildPackage,luci-app-splash))
+$(eval $(call BuildPackage,luci-app-statistics))
$(eval $(call BuildPackage,luci-sgi-haserl))
$(eval $(call BuildPackage,luci-sgi-webuci))