summaryrefslogtreecommitdiffhomepage
path: root/contrib
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-08-18 17:21:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-08-18 17:21:54 +0000
commitc82392c6f2befa4ceb03fceceed9f294d831bc66 (patch)
treecee1d61c0e37b80b21e27c6da69e268a430c8de4 /contrib
parent7be32a933262a3190cb105f1b038fab81be8a748 (diff)
* luci/contrib: use bleeding edge uci version from git
Diffstat (limited to 'contrib')
-rw-r--r--contrib/uci/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index a153203b2..13b0570da 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -1,18 +1,23 @@
include ../../build/config.mk
include ../../build/gccconfig.mk
-UCI_VERSION = 0.4.8
-UCI_SITE = http://mirror2.openwrt.org/sources
-UCI_DIR = uci-$(UCI_VERSION)
-UCI_FILE = $(UCI_DIR).tar.gz
-UCI_URL = $(UCI_SITE)/$(UCI_FILE)
+#UCI_VERSION = 0.4.8
+#UCI_SITE = http://mirror2.openwrt.org/sources
+#UCI_DIR = uci-$(UCI_VERSION)
+#UCI_FILE = $(UCI_DIR).tar.gz
+#UCI_URL = $(UCI_SITE)/$(UCI_FILE)
+UCI_VERSION = 0.4.8+git20080818-1
+UCI_SITE = http://nbd.name
+UCI_DIR = uci.git
+UCI_FILE = 672d68a8765c242dd939a31b520acbe1c9c1d7c2.tar.gz
+UCI_URL = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=672d68a8765c242dd939a31b520acbe1c9c1d7c2
all: compile
include ../../build/module.mk
$(UCI_FILE):
- wget -O $@ $(UCI_URL) || rm -f $@
+ wget -O $@ "$(UCI_URL)" || rm -f $@
$(UCI_DIR)/.prepared: $(UCI_FILE)
rm -rf $(UCI_DIR)