summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-09-02 09:41:14 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-09-02 09:41:14 +0200
commit62b203d0ea5bb0367c99bd4978edfe86908e427c (patch)
tree0364d2b6febfb6b3ec6c40533e543f2d6440c3d6 /contrib/uci/Makefile
parent16b63cb471eafb80eddb27165bdfa70cc5812821 (diff)
contrib: remove obsolete host uci configurations
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Diffstat (limited to 'contrib/uci/Makefile')
-rw-r--r--contrib/uci/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
deleted file mode 100644
index d04c5a146..000000000
--- a/contrib/uci/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-include ../../build/config.mk
-include ../../build/gccconfig.mk
-
-UCI_VERSION = 0.8.0
-#UCI_SITE = http://mirror2.openwrt.org/sources
-#UCI_DIR = uci-$(UCI_VERSION)
-#UCI_FILE = $(UCI_DIR).tar.gz
-#UCI_URL = $(UCI_SITE)/$(UCI_FILE)
-UCI_GITREV = aa3ab8012bfbf793d2884c08ea924545a04e9544
-UCI_SITE = http://nbd.name
-UCI_DIR = uci.git
-UCI_FILE = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
-UCI_URL = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
-UCI_PATCHDIR = patches
-
-all: compile
-
-include ../../build/module.mk
-
-$(UCI_FILE):
- wget -O $@ "$(UCI_URL)" || rm -f $@
-
-$(UCI_DIR)/.prepared: $(UCI_FILE)
- rm -rf $(UCI_DIR)
- tar xvfz $(UCI_FILE)
- (cd $(UCI_PATCHDIR); ls *.patch | sort > series) || true
- [ -f "$(UCI_PATCHDIR)/series" ] && while read patch; do \
- patch -d $(UCI_DIR) -p1 < $(UCI_PATCHDIR)/$$patch; \
- done < $(UCI_PATCHDIR)/series || true
- touch $@
-
-compile: $(UCI_DIR)/.prepared
- $(MAKE) -C $(UCI_DIR) CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
- mkdir -p dist/usr/lib dist/usr/bin
- $(MAKE) -C $(UCI_DIR) install DESTDIR=../dist prefix=/usr
- $(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
- $(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
-
-compile-all: compile
-
-clean:
- rm -rf $(UCI_PATCHDIR)/series
- rm -rf $(UCI_DIR) $(UCI_FILE)