summaryrefslogtreecommitdiffhomepage
path: root/contrib/uci/Makefile
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-08-27 21:32:05 +0000
committerSteven Barth <steven@midlink.org>2008-08-27 21:32:05 +0000
commit11bcdfd91aab8976c8f3e6bd6ca2fa0c45956adf (patch)
tree8abf1f85bac75ccd79b76ae704c3cc2d98fd14c2 /contrib/uci/Makefile
parent2cb538705485aa35c2193cacb11e103c70d8dc4e (diff)
Switch back to mainline UCI
Diffstat (limited to 'contrib/uci/Makefile')
-rw-r--r--contrib/uci/Makefile42
1 files changed, 11 insertions, 31 deletions
diff --git a/contrib/uci/Makefile b/contrib/uci/Makefile
index bac8ee8ac..31551af57 100644
--- a/contrib/uci/Makefile
+++ b/contrib/uci/Makefile
@@ -1,17 +1,16 @@
include ../../build/config.mk
include ../../build/gccconfig.mk
-UCI_VERSION = 0.6.0
-UCI_APPEND = +luci2
-#UCI_SITE = http://mirror2.openwrt.org/sources
-#UCI_DIR = uci-$(UCI_VERSION)
-#UCI_FILE = $(UCI_DIR).tar.gz
-#UCI_URL = $(UCI_SITE)/$(UCI_FILE)
-UCI_GITREV = a5256582f5a554c0cbcf45d19bb751e60ea42ce9
-UCI_SITE = http://nbd.name
-UCI_DIR = uci.git
-UCI_FILE = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
-UCI_URL = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
+UCI_VERSION = 0.6.1
+UCI_SITE = http://mirror2.openwrt.org/sources
+UCI_DIR = uci-$(UCI_VERSION)
+UCI_FILE = $(UCI_DIR).tar.gz
+UCI_URL = $(UCI_SITE)/$(UCI_FILE)
+#UCI_GITREV = 43124956bc9c1083e476f6cadaedf27b7788d004
+#UCI_SITE = http://nbd.name
+#UCI_DIR = uci.git
+#UCI_FILE = uci-$(UCI_VERSION)$(UCI_APPEND).tar.gz
+#UCI_URL = $(UCI_SITE)/gitweb.cgi?p=uci.git;a=snapshot;h=$(UCI_GITREV)
UCI_PATCHDIR = patches
all: compile
@@ -27,33 +26,14 @@ $(UCI_PATCHDIR)/series:
$(UCI_DIR)/.prepared: $(UCI_FILE)
rm -rf $(UCI_DIR)
tar xvfz $(UCI_FILE)
- ln -s ../$(UCI_PATCHDIR) $(UCI_DIR)/patches
touch $@
-$(UCI_DIR)/.patched: $(UCI_DIR)/.prepared $(UCI_PATCHDIR)/series
- (cd $(UCI_DIR); \
- if [ -x "$$(which quilt 2>/dev/null)" ]; then \
- quilt push -a; \
- else \
- cat patches/*.patch | patch -p1; \
- fi; \
- )
- touch $@
-
-refresh: $(UCI_DIR)/.patched
- (cd $(UCI_DIR); \
- for i in $$(quilt series); do \
- quilt refresh $$i; \
- done; \
- )
-
-compile: $(UCI_DIR)/.patched
+compile: $(UCI_DIR)/.prepared
$(MAKE) -C $(UCI_DIR) CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
mkdir -p dist/usr/lib dist/usr/bin
$(MAKE) -C $(UCI_DIR) install DESTDIR=../dist prefix=/usr
$(MAKE) -C $(UCI_DIR)/lua CC=$(CC) CFLAGS="$(CFLAGS)" LDFLAGS="$(LDFLAGS)" OS="$(OS)"
$(MAKE) -C $(UCI_DIR)/lua install DESTDIR=../../dist luadir=$(LUA_LIBRARYDIR)
- mv dist$(LUA_LIBRARYDIR)/uci.so dist$(LUA_LIBRARYDIR)/uci2.so
compile-all: compile