summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-01 12:22:47 +0000
committerSteven Barth <steven@midlink.org>2008-06-01 12:22:47 +0000
commite1c469e6341010a0831f389e609648978026590d (patch)
tree3e1c078f050c9c562013dba4350aaab7d038a299 /contrib/package
parentb454395a8da4013aff2ecd64cd7eafc01fc6a5a2 (diff)
* Added OpenWRT package for english translation (incomplete)
* libs/core: Fixed indentation of luci.util.strip_bytecode
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile25
1 files changed, 24 insertions, 1 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index d0c924af6e..975c13025a 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -48,6 +48,12 @@ define Package/luci/fftemplate
DEPENDS:=+luci-mod-freifunk
endef
+define Package/luci/i18ntemplate
+ $(call Package/luci/libtemplate)
+ SUBMENU:=LuCI - Translations
+ DEPENDS:=+luci-web
+endef
+
define Package/luci/thtemplate
$(call Package/luci/libtemplate)
SUBMENU:=LuCI - Themes
@@ -297,7 +303,7 @@ define Package/luci-sgi-webuci/install
$(call Package/luci/install/template,$(1),libs/sgi-webuci)
endef
-### Templates ###
+### Themes ###
define Package/luci-theme-fledermaus
$(call Package/luci/fftemplate)
DEPENDS:=+luci-web
@@ -317,6 +323,17 @@ define Package/luci-theme-openwrt/install
$(call Package/luci/install/template,$(1),themes/openwrt.org)
endef
+### Translations ###
+define Package/luci-i18n-english
+ $(call Package/luci/i18ntemplate)
+ TITLE:=English (incomplete)
+endef
+
+define Package/luci-i18n-english/install
+ $(call Package/luci/install/template,$(1),i18n/english)
+endef
+
+
### Compile ###
ifneq ($(CONFIG_PACKAGE_luci-core),)
@@ -373,6 +390,10 @@ ifneq ($(CONFIG_PACKAGE_luci-theme-openwrt),)
PKG_SELECTED_MODULES+=themes/openwrt.org
endif
+ifneq ($(CONFIG_PACKAGE_luci-i18n-english),)
+ PKG_SELECTED_MODULES+=i18n/english
+endif
+
$(eval $(call BuildPackage,luci-core))
$(eval $(call BuildPackage,luci-cbi))
@@ -395,3 +416,5 @@ $(eval $(call BuildPackage,luci-sgi-webuci))
$(eval $(call BuildPackage,luci-theme-fledermaus))
$(eval $(call BuildPackage,luci-theme-openwrt))
+
+$(eval $(call BuildPackage,luci-i18n-english))