summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-06-20 16:47:25 +0000
committerSteven Barth <steven@midlink.org>2008-06-20 16:47:25 +0000
commite2e9e119d670ec80954fc8c018b479b218a7e47e (patch)
tree25c5fcd2edc1581ac547cdc30bdb28e2dfedb2ad /contrib/package
parent8349a0504e3d69586e783f9327428301528a634c (diff)
* Moved luci.http.protocol to libs/http
* Added ltn12 to libs/core * Fixed libs/httpd Makefile
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index b2571f750..8b03f7956 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -132,9 +132,19 @@ define Package/luci-fastindex/install
endef
+define Package/luci-http
+ $(call Package/luci/libtemplate)
+ TITLE:=HTTP Protocol implementation
+endef
+
+define Package/luci-http/install
+ $(call Package/luci/install/template,$(1),libs/http)
+endef
+
+
define Package/luci-web
$(call Package/luci/libtemplate)
- DEPENDS+=+luci-addons +luci-uci
+ DEPENDS+=+luci-http +luci-addons +luci-uci
TITLE:=MVC Webframework
endef
@@ -384,6 +394,9 @@ endif
ifneq ($(CONFIG_PACKAGE_luci-fastindex),)
PKG_SELECTED_MODULES+=libs/fastindex
endif
+ifneq ($(CONFIG_PACKAGE_luci-http),)
+ PKG_SELECTED_MODULES+=libs/http
+endif
ifneq ($(CONFIG_PACKAGE_luci-uci),)
PKG_SELECTED_MODULES+=libs/uci
endif
@@ -455,6 +468,7 @@ MAKE_FLAGS += MODULES="$(PKG_SELECTED_MODULES)" LUA_TARGET="$(LUA_TARGET)" CFLAG
$(eval $(call BuildPackage,luci-core))
$(eval $(call BuildPackage,luci-cbi))
$(eval $(call BuildPackage,luci-fastindex))
+$(eval $(call BuildPackage,luci-http))
$(eval $(call BuildPackage,luci-uci))
$(eval $(call BuildPackage,luci-web))