summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-05-27 08:14:24 +0000
committerSteven Barth <steven@midlink.org>2008-05-27 08:14:24 +0000
commitb8124f18f88fe11158eb122a1e362cfbd512cf4f (patch)
tree2d7e9044ddb656c83de73415240c4ded59622389 /contrib/package
parentd4399bf6189977336a94795f25986fb89a22a5e7 (diff)
* Separated the MVC-Webframework from core
* Separated i18n from core to prepare translations
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 2458ebd28..c75247b55 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -46,19 +46,32 @@ endef
define Package/luci
$(call Package/luci/template)
MENU:=1
- DEPENDS:=+lua +luaposix +luci-addons
+ DEPENDS:=+lua +luaposix
endef
-define Package/luci/conffiles
+define Package/luci/install
+ $(call Package/luci/install/template,$(1),core)
+endef
+
+
+### Web Packages ###
+define Package/luci-web
+ $(call Package/luci/template)
+ DEPENDS:=luci +luci-addons
+ TITLE:=LuCI - Webframework
+endef
+
+define Package/luci-web/conffiles
/etc/config/luci
endef
-define Package/luci/install
- $(call Package/luci/install/template,$(1),core)
+define Package/luci-web/install
+ $(call Package/luci/install/template,$(1),web)
$(call Package/luci/install/template,$(1),themes/fledermaus)
endef
+
### Community Packages ###
define Package/luci-ff-halle
@@ -111,7 +124,7 @@ endef
define Package/luci-mod-admin-core
$(call Package/luci/template)
- DEPENDS:=luci
+ DEPENDS:=luci +luci-web
TITLE:=Core administrative pages
endef