summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorSteven Barth <steven@midlink.org>2008-03-31 22:24:32 +0000
committerSteven Barth <steven@midlink.org>2008-03-31 22:24:32 +0000
commit184f13334f470141420a189220dd3b951aac4480 (patch)
treea110745e118b4970362599e8b45272506f67f9ba /contrib/package
parent746fdf6b472e72cb01b0c3510cc3eb04be1237b7 (diff)
* Fixed haserl-lua Makefile
* Fixed a bug in CBI that occured when target UCI is empty * Added frontend for port forwarding / firewall pages
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/ffluci/Makefile3
-rw-r--r--contrib/package/ffluci/ipkg/conffiles3
-rw-r--r--contrib/package/haserl-lua/Makefile2
3 files changed, 5 insertions, 3 deletions
diff --git a/contrib/package/ffluci/Makefile b/contrib/package/ffluci/Makefile
index 3bf9eb596..753fe889a 100644
--- a/contrib/package/ffluci/Makefile
+++ b/contrib/package/ffluci/Makefile
@@ -44,7 +44,8 @@ define Package/ffluci/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/ffluci $(1)/www/cgi-bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/index.cgi $(1)/www/cgi-bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/contrib/index.html $(1)/www
- $(CP) $(PKG_BUILD_DIR)/contrib/ffluci.uci $(1)/etc/config/luci
+ $(CP) $(PKG_BUILD_DIR)/contrib/uci/luci $(1)/etc/config/luci
+ $(CP) $(PKG_BUILD_DIR)/contrib/uci/luci_fw $(1)/etc/config/luci_fw
$(CP) -a ./ipkg/ffluci.postinst $(1)/CONTROL/postinst
$(CP) -a ./ipkg/conffiles $(1)/CONTROL/conffiles
endef
diff --git a/contrib/package/ffluci/ipkg/conffiles b/contrib/package/ffluci/ipkg/conffiles
index 5258af4d8..098dbf904 100644
--- a/contrib/package/ffluci/ipkg/conffiles
+++ b/contrib/package/ffluci/ipkg/conffiles
@@ -1 +1,2 @@
-/etc/config/luci \ No newline at end of file
+/etc/config/luci
+/etc/config/luci_fw \ No newline at end of file
diff --git a/contrib/package/haserl-lua/Makefile b/contrib/package/haserl-lua/Makefile
index b2146334c..c531d3399 100644
--- a/contrib/package/haserl-lua/Makefile
+++ b/contrib/package/haserl-lua/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
-PKG_NAME:=haserl-lua
+PKG_NAME:=haserl
PKG_VERSION:=0.9.23
PKG_RELEASE:=1