summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2008-06-08 22:23:57 +0000
committerJo-Philipp Wich <jow@openwrt.org>2008-06-08 22:23:57 +0000
commit004213483340028437736f5810bd1c2274b7b72c (patch)
tree860a06ea53460324ba3cdbe19ee56f6cf7bb35ec /contrib/package
parent5f6561bc3408fa350a8403bee364186a5b946694 (diff)
* luci/statistics: add postinstall for package, fix permissions of luci-ff-hannover.postinst
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile1
-rwxr-xr-x[-rw-r--r--]contrib/package/luci/ipkg/luci-ff-hannover.postinst0
-rwxr-xr-xcontrib/package/luci/ipkg/luci-statistics.postint4
3 files changed, 5 insertions, 0 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index f94171523..b438760f5 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -317,6 +317,7 @@ define Package/luci-app-statistics/install
$(call Package/luci/install/template,$(1),applications/luci-statistics)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/usr/bin/stat-genconfig $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/applications/luci-statistics/dist/etc/init.d/luci_statistics $(1)/etc/init.d
+ $(CP) -a ./ipkg/luci-statistics.postinst $(1)/CONTROL/postinst
endef
diff --git a/contrib/package/luci/ipkg/luci-ff-hannover.postinst b/contrib/package/luci/ipkg/luci-ff-hannover.postinst
index b41179f72..b41179f72 100644..100755
--- a/contrib/package/luci/ipkg/luci-ff-hannover.postinst
+++ b/contrib/package/luci/ipkg/luci-ff-hannover.postinst
diff --git a/contrib/package/luci/ipkg/luci-statistics.postint b/contrib/package/luci/ipkg/luci-statistics.postint
new file mode 100755
index 000000000..69fe0c016
--- /dev/null
+++ b/contrib/package/luci/ipkg/luci-statistics.postint
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ -n "${IPKG_INSTROOT}" ] || {
+ ( . /etc/uci-defaults/luci-statistics ) && rm -f /etc/uci-defaults/luci-statistics
+}