summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-01-23 01:49:54 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-01-23 01:49:54 +0000
commit03ad47080cc869051af58f91769da4faf503e151 (patch)
tree78ef0ffe46a578a9892115658e788b69a303db04 /contrib/package
parent02977e53298dbcede2e4932b270f4ac23b51e014 (diff)
contrib, build: bundle LuaSrcDiet and make it available in build targets
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/luci/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/contrib/package/luci/Makefile b/contrib/package/luci/Makefile
index 0427e4b59..45039a1c7 100644
--- a/contrib/package/luci/Makefile
+++ b/contrib/package/luci/Makefile
@@ -103,6 +103,9 @@ define Package/luci-lib-core/config
config PACKAGE_luci-lib-core_stripped
bool "Stripped"
+ config PACKAGE_luci-lib-core_srcdiet
+ bool "Compressed Source"
+
config PACKAGE_luci-lib-core_source
bool "Full Source"
@@ -117,8 +120,8 @@ ifneq ($(CONFIG_PACKAGE_luci-lib-core_stripped),)
LUA_TARGET:=strip
endif
-ifneq ($(CONFIG_PACKAGE_luci-lib-core_zipped),)
- LUA_TARGET:=gzip
+ifneq ($(CONFIG_PACKAGE_luci-lib-core_srcdiet),)
+ LUA_TARGET:=diet
endif
ifneq ($(CONFIG_PACKAGE_luci-lib-core),)