summaryrefslogtreecommitdiffhomepage
path: root/contrib/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-01-22 23:16:37 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-01-22 23:16:37 +0000
commit72b276d92d18867046d05f92864817e5883e2145 (patch)
treee1a8842546cc104fb22e791ec797a7fb6816ddea /contrib/package
parent661ead324112a850a73fa2e2433a40c3b031f235 (diff)
contrib/package: remove definitions for pgraph plugin
Diffstat (limited to 'contrib/package')
-rw-r--r--contrib/package/olsrd-luci/Makefile17
1 files changed, 2 insertions, 15 deletions
diff --git a/contrib/package/olsrd-luci/Makefile b/contrib/package/olsrd-luci/Makefile
index 85f55b2d6..459f1c3e4 100644
--- a/contrib/package/olsrd-luci/Makefile
+++ b/contrib/package/olsrd-luci/Makefile
@@ -12,7 +12,7 @@ include $(TOPDIR)/rules.mk
PKG_BASENAME:=olsrd
PKG_NAME:=$(PKG_BASENAME)-luci
PKG_VERSION:=0.5.6-r3+hg2227
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_HGREV:=a7316f987848
PKG_SOURCE:=$(PKG_HGREV).tar.gz
@@ -111,13 +111,6 @@ define Package/olsrd-luci-mod-txtinfo
DEPENDS:=olsrd-luci
endef
-define Package/olsrd-luci-mod-pgraph
- $(call Package/olsrd-luci/common_info)
- MENU:=1
- TITLE:=OLSR - PGraph Plugin
- DEPENDS:=olsrd-luci
-endef
-
define Package/olsrd-luci-mod-quagga
$(call Package/olsrd-luci/common_info)
MENU:=1
@@ -140,7 +133,7 @@ define Build/Compile
MANDIR="$(PKG_INSTALL_DIR)/usr/share/man" \
STRIP="true" \
INSTALL_LIB="true" \
- SUBDIRS="arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo nameservice secure txtinfo pgraph quagga"
+ SUBDIRS="arprefresh bmf dot_draw dyn_gw dyn_gw_plain httpinfo nameservice secure txtinfo quagga"
endef
define Package/olsrd-luci/install
@@ -197,11 +190,6 @@ define Package/olsrd-luci-mod-txtinfo/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/txtinfo/olsrd_txtinfo.so.* $(1)/usr/lib/
endef
-define Package/olsrd-luci-mod-pgraph/install
- $(INSTALL_DIR) $(1)/usr/lib
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/pgraph/olsrd_pgraph.so.* $(1)/usr/lib/
-endef
-
define Package/olsrd-luci-mod-quagga/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/quagga/olsrd_quagga.so.* $(1)/usr/lib/
@@ -218,5 +206,4 @@ $(eval $(call BuildPackage,olsrd-luci-mod-httpinfo))
$(eval $(call BuildPackage,olsrd-luci-mod-nameservice))
$(eval $(call BuildPackage,olsrd-luci-mod-secure))
$(eval $(call BuildPackage,olsrd-luci-mod-txtinfo))
-$(eval $(call BuildPackage,olsrd-luci-mod-pgraph))
$(eval $(call BuildPackage,olsrd-luci-mod-quagga))