summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/uhttpd
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-19 01:36:30 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-19 01:36:30 +0000
commita7282c83787272d98a3c6bc8f5313987c0ae3d96 (patch)
treeb76abadc0102d7bcb63dc194d5765a3715de5189 /contrib/package/uhttpd
parent77f310f5db4b9cd5a98adbf198c3eb9d36632cb7 (diff)
uhttpd: add a workaround to use CyaSSL's openssl/ssl.h header, it is not 100% OpenSSL compatible after all
Diffstat (limited to 'contrib/package/uhttpd')
-rw-r--r--contrib/package/uhttpd/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/contrib/package/uhttpd/Makefile b/contrib/package/uhttpd/Makefile
index e2455ed26..ec37b2eab 100644
--- a/contrib/package/uhttpd/Makefile
+++ b/contrib/package/uhttpd/Makefile
@@ -27,14 +27,14 @@ define Package/uhttpd/description
HTTP daemon.
endef
+# hack to use CyASSL headers
+TARGET_CFLAGS += -I$(firstword $(wildcard $(BUILD_DIR)/cyassl-*/include))
+
define Build/Prepare
mkdir -p $(PKG_BUILD_DIR)
$(CP) ./src/* $(PKG_BUILD_DIR)/
endef
-TARGET_CFLAGS += --std=c99 -D_POSIX_C_SOURCE=200112L -D_XOPEN_SOURCE=500
-TARGET_LDFLAGS += -lz -lm -lcrypt
-
define Package/uhttpd/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/sbin/