summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/uhttpd/src/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-19 01:35:26 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-19 01:35:26 +0000
commit77f310f5db4b9cd5a98adbf198c3eb9d36632cb7 (patch)
tree2f0a22808dba693dc1cece057d2e03f05e2f751a /contrib/package/uhttpd/src/Makefile
parent0799c5f9ea70ddc5cc958cea74a6e066fea12f80 (diff)
uhttpd: make missing certs only fatal if tls sockets were requested
Diffstat (limited to 'contrib/package/uhttpd/src/Makefile')
-rw-r--r--contrib/package/uhttpd/src/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/contrib/package/uhttpd/src/Makefile b/contrib/package/uhttpd/src/Makefile
index 44bed22d86..a94dff9f8d 100644
--- a/contrib/package/uhttpd/src/Makefile
+++ b/contrib/package/uhttpd/src/Makefile
@@ -1,10 +1,13 @@
-CGI_SUPPORT:=1
-LUA_SUPPORT:=1
-TLS_SUPPORT:=0
+CGI_SUPPORT ?= 1
+LUA_SUPPORT ?= 1
+TLS_SUPPORT ?= 1
LDFLAGS ?= -L./lua-5.1.4/src -L./cyassl-1.4.0/src/.libs -lm
CFLAGS ?= -Wall -I./lua-5.1.4/src -I./cyassl-1.4.0/include -O0 -ggdb3
+CFLAGS += --std=c99 -D_POSIX_C_SOURCE=200112L -D_XOPEN_SOURCE=500
+LDFLAGS += -lm -lcrypt
+
OBJ = uhttpd.o uhttpd-file.o uhttpd-utils.o
ifeq ($(CGI_SUPPORT),1)
@@ -21,7 +24,7 @@ endif
ifeq ($(TLS_SUPPORT),1)
OBJ += uhttpd-tls.o
CFLAGS += -DHAVE_TLS
- LDFLAGS += -lcyassl
+ LDFLAGS += -lpthread -lz -lcyassl
endif
%.o: %.c