summaryrefslogtreecommitdiffhomepage
path: root/contrib/package/uhttpd/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-03-19 09:22:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-03-19 09:22:15 +0000
commit5f343a22e1a3cfe8736484ae9f239613e6647f9f (patch)
treea96cfff5fa3f01ce49a7f18c4af273e7a472f902 /contrib/package/uhttpd/Makefile
parent60f7191ff4609ebd056eb4a326f29a49b3c32fb5 (diff)
uhttpd: add init script and uci configuration
Diffstat (limited to 'contrib/package/uhttpd/Makefile')
-rw-r--r--contrib/package/uhttpd/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/contrib/package/uhttpd/Makefile b/contrib/package/uhttpd/Makefile
index ec37b2eab0..802fb209e6 100644
--- a/contrib/package/uhttpd/Makefile
+++ b/contrib/package/uhttpd/Makefile
@@ -18,7 +18,7 @@ define Package/uhttpd
SECTION:=net
CATEGORY:=Network
TITLE:=uHTTPd - tiny, single threaded HTTP server
- DEPENDS:=+liblua +libcyassl
+ DEPENDS:=+liblua +libcyassl +zlib
endef
define Package/uhttpd/description
@@ -35,9 +35,17 @@ define Build/Prepare
$(CP) ./src/* $(PKG_BUILD_DIR)/
endef
+define Package/uhttpd/conffiles
+/etc/config/uhttpd
+endef
+
define Package/uhttpd/install
- $(INSTALL_DIR) $(1)/sbin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/sbin/
+ $(INSTALL_DIR) $(1)/etc/init.d
+ $(INSTALL_BIN) ./files/uhttpd.init $(1)/etc/init.d/uhttpd
+ $(INSTALL_DIR) $(1)/etc/config
+ $(INSTALL_CONF) ./files/uhttpd.config $(1)/etc/config/uhttpd
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
endef
$(eval $(call BuildPackage,uhttpd))